Running complex id example with rtps-multicast configuration in opendds

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
[+] NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System
[+] Linux

Hardware Platform
[+] NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
[+] native Ubuntu 18.04

We tried to run the complex idl example with rtps-multicast configuration but the data was not able to communicate between publisher and subscriber.
In the document " Open data distribution service on linux.pdf" provided by nvidia it has shown on the page 12 as,
But we are unsure how to do this as we are not able to find the tegra_t186ref_gnu_linux_defconfig file.

Could you please give us the steps we need to follow to run the example in multicast configuration?

thank you,

@nithin.m1 we will take a look and get back to you.

Hi @VickNV,

Any update on above query?

There is a doc issue that the defconfig file name should be “tegra_defconfig” (in path drive-oss-src/kernel/arch/arm64/configs), not what’s listed.
Please see if it helps with the problem.

Thanks @VickNV,
We found the file and found the flag to be valid, but still we are unable to run the example for our use-case.
Our use-case is to run the publisher on one agx and the subsriber on another agx, both are connected using ethernet ports, what configuration changes needs to be done in the configuration .ini file, could you please guide us on this.

Please share the detailed steps of what you have tried so I can review it with our team. Thanks.