Running detetctnet with usb camera shuts down TX1

Hello,
I have compiled the jetson-inference successfully . but when i run the detectnet-camera in the jetson-inference/build/aarch64/bin directory using USB camera (econ usb cam) it immediately shuts down the machine . Any suggestion how to overcome this situation
to be noted: i did change the default camera as 0 as suggested in the instructions.

Best regards

Hi,

Did you do this change to enable usb camera?

note: by default, the Jetson’s onboard CSI camera will be used as the video source. If you wish to use a USB webcam instead, change the DEFAULT_CAMERA define at the top of imagenet-camera.cpp to reflect the /dev/video V4L2 device of your USB camera. The model it’s tested with is Logitech C920.

Mentioned in https://github.com/dusty-nv/jetson-inference#running-the-live-camera-recognition-demo

I have changed the DEFAULT_CAMERA defined at the top of detectnet-camera,however,the usb camera I used is econ usb cam .

I am curious, if you use a serial cosole, does anything show up on dmesg or the console at the moment of the shutdown? Also, can you try powering the camera through a powered HUB if the camera is not already independent of the Jetson’s power?

Hi,

Not all the v4l2 camera connect to ‘/dev/video0’.

For example, my camera is connected to ‘/dev/video1’.
(You can check this via connecting and dis-connecting usb-camera)

So I change it into

#define DEFAULT_CAMERA 1

hi,linuxdev
I provide the power for usb camera with a powered HUB,tx1 still shut down without any error message.

This phenomenon only appears when I run the detectnet-camera,if I delete those codes about detecting in detectnet-camera.cpp,it works well.

Hi,

Just want to confirm that:
The camera works if only capture and display without inferencing?

yes

Hi,

We will try to reproduce this on our side.
Do you have another camera could help us give it a try?

And could you share some log information, like ‘/var/log/syslog’?

Thanks

Hi,

We try to reproduce this issue with three different brands of web cameras. But none of them met this shutdown problem.

It looks like camera-dependent.
Could you share /var/log/syslog and v4l2-ctl device info to us?
Thanks.

Hello,

I have the same problem with my TX1 and Auvidea J120. I tested with another board and I have the same result: a shutdown only if I use CUDA (with USB camera or not).

I use Jetpack 3.2 but with 3.1 the problem is the same.

The problem only occurs in exhibitions. At my office the only time I had the problem is with a 3A power supply (I consume ~2A in operation).

The logs are empty, no errors.

Do you have an idea of how to solve this problem?

Please check the usb camera with ‘v4l2-ctl --list-formats-ext’ You may see prints such as:

ioctl: VIDIOC_ENUM_FMT 
Index : 0 
Type : Video Capture 
Pixel Format: 'YUYV' 
Name : YUYV 4:2:2 
Size: Discrete 640x480 
Interval: Discrete 0.033s (30.000 fps) 
Interval: Discrete 0.042s (24.000 fps) 
Interval: Discrete 0.050s (20.000 fps) 
Interval: Discrete 0.067s (15.000 fps) 
Interval: Discrete 0.100s (10.000 fps) 
Interval: Discrete 0.133s (7.500 fps) 
Interval: Discrete 0.200s (5.000 fps)

In this example it can run 640x480p30 YUYV formats. In this case, the launch string should be

v4l2src device=/dev/video0 ! video/x-raw, width=(int)640, height=(int)480, format=YUY2 ! videoconvert ! video/x-raw, format=RGB ! appsink name=mysink

You can run the launch string via ‘gst-launch-1.0’ to ensure its correctness.