Running Digits from modprobe error


I’ve been having trouble running DIGITS from the NVIDIA GPU Cloud.

Problem: when I call nvidia-docker run -it --rm -v /Desktop/jetson_projects:/
I get the following error:

nvidia-docker | 2018/04/17 15:57:24 Error: Could not load UVM kernel module. Is nvidia-modprobe installed?

I’m currently using an Ubuntu 16.04 VM for my host pc (dusty-inference github).

This is what i get when I run dpkg -l | grep -i docker:
ii docker-ce 18.03.0~ce-0~ubuntu amd64 Docker: the open-source application container engine
ii nvidia-container-runtime 2.0.0+docker18.03.0-1 amd64 NVIDIA container runtime
ii nvidia-docker 1.0.1-1 amd64 NVIDIA Docker container tools

and when I run docker info:
Containers: 2
Running: 0
Paused: 0
Stopped: 2
Images: 3
Server Version: 18.03.0-ce
Storage Driver: overlay2
Backing Filesystem: extfs
Supports d_type: true
Native Overlay Diff: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
Volume: local
Network: bridge host macvlan null overlay
Log: awslogs fluentd gcplogs gelf journald json-file logentries splunk syslog
Swarm: inactive
Runtimes: nvidia runc
Default Runtime: runc
Init Binary: docker-init
containerd version: cfd04396dc68220d1cecbe686a6cc3aa5ce3667c
runc version: 4fc53a81fb7c994640722ac585fa9ca548971871
init version: 949e6fa
Security Options:
Profile: default
Kernel Version: 4.13.0-36-generic
Operating System: Ubuntu 16.04.4 LTS
OSType: linux
Architecture: x86_64
CPUs: 1
Total Memory: 3.759GiB
Name: kp-VirtualBox
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Experimental: false
Insecure Registries:
Live Restore Enabled: false

WARNING: No swap limit support

and when I run docker version:
Version: 18.03.0-ce
API version: 1.37
Go version: go1.9.4
Git commit: 0520e24
Built: Wed Mar 21 23:10:01 2018
OS/Arch: linux/amd64
Experimental: false
Orchestrator: swarm

Version: 18.03.0-ce
API version: 1.37 (minimum version 1.12)
Go version: go1.9.4
Git commit: 0520e24
Built: Wed Mar 21 23:08:31 2018
OS/Arch: linux/amd64
Experimental: false

and apt show nvidia-docker2:
ackage: nvidia-docker2
Version: 2.0.3+docker18.03.0-1
Priority: optional
Section: utils
Installed-Size: 18.4 kB
Depends: nvidia-container-runtime (= 2.0.0+docker18.03.0-1), docker-ce (= 18.03.0~ce-0~ubuntu) | docker-ee (= 18.03.0~ee-0~ubuntu)
Breaks: nvidia-docker (<< 2.0.0)
Replaces: nvidia-docker (<< 2.0.0)
Download-Size: 2,888 B
APT-Sources: Packages
Description: nvidia-docker CLI wrapper
Replaces nvidia-docker with a new implementation based on

N: There are 27 additional records. Please use the ‘-a’ switch to see them.

Is this simply not possible within an Ubuntu VM? Are there other ways of running with docker?