Running kernels for more than a few seconds in Win7


I’ve read the sticky thread about this and changed the registry settings. While the GFX card does not reset now, Win7 seems to take about 15 minutes to recover from a 60 second kernel run.

To get around this, I’ve tried to decouple the GTX590 from its graphics duties by using a cheap USB-VGA device to show the desktop on a second monitor. This works from a graphics point of view in that I can order Windows to use only the second monitor and the monitor connected to the GTX590 goes blank.
So far. so good…but when I now try to run a CUDA program it complains about not being able to find a CUDA device.

Maybe I’ve misconfigured something, but before I spend time trying an infinite amount of windows settings, I’d like to ask the forum if this approach is likely to work?

…or maybe suggest a better idea?

Not running the desktop on a GPU to disable the watchdog timer works only with Tesla cards or under Linux.