Runtime_source_add_delete python-apps not working

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) ::---- Tesla T4
• DeepStream Version ::—
• JetPack Version (valid for Jetson only) ::- NA
• TensorRT Version ::-
• NVIDIA GPU Driver Version (valid for GPU only) :- 510.85.02
• Issue Type( questions, new requirements, bugs) :- questions
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
python3 rtsp::________________________________
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

I have tried the deepstream-python-apps code for runtime_source_add_delete , I tried runnning the code without changing any parameters. I got the following error.

In cb_newpad

gstname= video/x-raw
Decodebin linked to pipeline
0:00:35.590904789  1039      0x28c3760 WARN                 nvinfer gstnvinfer.cpp:2299:gst_nvinfer_output_loop:<secondary3-nvinference-engine> error: Internal data stream error.
0:00:35.590952423  1039      0x28c3760 WARN                 nvinfer gstnvinfer.cpp:2299:gst_nvinfer_output_loop:<secondary3-nvinference-engine> error: streaming stopped, reason not-negotiated (-4)
Error: gst-stream-error-quark: Internal data stream error. (1): gstnvinfer.cpp(2299): gst_nvinfer_output_loop (): /GstPipeline:pipeline0/GstNvInfer:secondary3-nvinference-engine:
streaming stopped, reason not-negotiated (-4)
Exiting app

Can anyone guide me to resove this issue. ?
Thanks in advance

Can anyone share the answer here please ?

sorry for the late reply, could you share more logs? please do “export GST_DEBUG=6” first to modify Gstreamer’s log level, then run again, you can redirect the logs to a file.


output.log (14.2 MB)

@fanzh ,
Please refer attached file output. after running GST_DEBUG=6./ Please let me know if anything more details
is required.

0:06:10.162351990 e[331m 120e[00m 0x1937760 e[31;01mERROR e[00m e[00m nveglglessink ext/eglgles/gsteglglessink.c:2907:gst_eglglessink_setcaps:e[00m Failed to configure caps

from the logs, it is releated to EGLImage,

  1. did you do " Run the container" steps in deepstream docker
  2. can you use fakesink or filesink or rtspstreaming instead of nveglglessink?

i’m running container following proper steps.
Sure I’ll try with fake_sink.

After the implementation fake sink,
I’m able to run the application, but no stream processing is not done.

I have attached the GST_DEBUG=6 response for source.

NOTE:- I notice that on the streammux, there is no sink_%u % source_id via the following check.

# output: **src**
# FYL streammux.pads contains only the source pad and no sink pads,
# hence we get a value of None when we call the following code: 
# streammux.get_static_pad(pad_name)  line 183 & 166.  
print(f'pad name: {streammux.pads[0].name}')
# Contains only one element (we need to add sink pad)
print(f'pad list: {streammux.pads}')

Link of log file :- nvidia-logs - Google Drive

File is about 300 MiB in size.

do you mean there is no file generated? you might use filesink to output results, please reuse this code:

@fanzh ,
I mean the the pad we are requesting to get details in from streammux ( sink_pad) doesn’t have the sink_%u named pad element in it. I tried printing it but I got the the pad name as src .

I tried chaning name to src, it stucks processing,

after implementing src I tried to save output using filesink ,It is not able to save ( i mean saved file size in 0 kb.

here is the method to get pad “sinkpad = streammux.get_static_pad(pad_name)”

please add encoder, codeparser, container, sink plugin to pipeleine, and link them, you can reuse the code in deepstream_python_apps/ at master · NVIDIA-AI-IOT/deepstream_python_apps · GitHub or

no luck.
still not fixing the issue.

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one. Thanks

as the code in opticalflow sample shown, need to add some encode related plugin, you might dump the pipeline to compare, here is the method to dump pipeline:Python DeepStream program not generating dot file

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.