SD Card Stopped Working


We have a custom carrier board for Jetson TX2.
The SD Card on the carrier board worked fine for almost a month.

The SD card stopped working yesterday. The device/dev/mmcblk2p1 is no longer listed in fdisk and lsblk outputs.

Is it possible to detect the problem based on the attached boot log?


Boot-Log.txt (17.7 KB)

I can not remove the SD card from the board to test its functionality on another machine, because the board has been conformal coated, and the coating unintentioanlly has been deposited on the SD card and its slot.

Rel-32 release has “quiet” keyword in kernel cmdline by default.

Which means your UART log by default won’t have full kernel log. Thus, your log does not have useful info.

Remove that one from extlinux.conf and dump the log again.

1 Like

Thanks for your quick reply.

Here is the complete log. ( I get different boot logs on different host machines using the same USB-to-Serial converter and I don’t know why…).

Boot-Log-2-mmcblk2.txt (73.7 KB)

Still not full log. Just print some more error logs didn’t mean it is complete log.

Thanks very much for your help and support.

Yes you are right.

I removed the “quiet” option from /boot/extlinx/extlinux.conf file, and got the following log:

Boot-Log.txt (71.3 KB)

If this last one is not the complete log, I don’t know what should I do.

This is full log but I don’t see any error from sdcard. Did you remove the card?

No I did not remove the card.

I am not sure what do you want me to help check here.

It is either hardware problem or sdcard problem. But as your said it seems you cannot remove the sdcard, we cannot do cross check here.


As you said, there is no error related to sd card, while the SD card is physically connected to the board. I think it means that the SD pins are somehow mechanically disconnected while the sd card is in its position.

My goal is to make sure that the SD has not been electrically damaged, and the problem is mechanical.

Thanks a lot for your help.

I have another question:

Is it possible that a failed SD card prevent Jetson TX2 from normal boot?

Your log didn’t show a boot failure. Could you try more times of test?

OK. I will do more times of power up test.

But I want to know is it possible (in theory) that a failed sd card eventually prevent the Jetson from normal power up after multiple times of power up and power down?

If there is kernel panic happend, then it will. If there is not, then shall not affect. Just lots of log would be printed.

1 Like

Many thanks for your help.

I powered up and down Jetson TX2 for multiple times, and the boot log changed, containing some errors related to SD card.

Attached is the new boot log.

Boot-Log-New.txt (146.4 KB)

login prompt is still there. Looks like not affecting the boot.


According to those errors, is it possible to guess about the problem?

Answer is still same. Either hardware defect or sdcard problem.

1 Like

New details in boot log after multiple power up and shut downs:

error -110 whilst initializing the SD card.
card never left busy state.