Jetson TX2 stopped powering up, and I need to recover the files inside

Hi, I was working through ssh with the Jetson TX2 dev kit everything normal, suddenly the board turned off. When I pressed the power button to turn it on again, all I get is a red led that turns on and then off. I really need some of the files inside, and would like to know if there’s a way to get them back? I tried the recovery mode sequence but get no device detected on Windows OS.

Hi agrazvallejo,

Can you power on anymore?
Please share the UART log. Thanks!

When I power on all I get is a RED LED turning on, then off and the nothing. How can I get the UART LOG?

Okay I did the following
-Jetson TX2 is powered off.
-Connected a TTL to USB adapter that uses with the PL2303 Serial Port.
-The TX, RX and GND pins from the Jetson TX2 J21 header go to the TTL side and the USB side goes into a Jetson Nano.
-Through minicom on the Nano, I setup minicom with 115200 baudrate, with 8 bits, no parity, and 1 stop bit, the I connected to the ttyUSB0 port (no other devices are connected)
-Restart Minicom.
-Turn on the TX2, but saw nothing on Minicom

Is there a way to get the data from the TX2 through other means?

I would be surprised if serial UART (if connected correctly) has no output (the basics you showed were correct). Quite often a complete failure of serial UART implies a hardware failure. However, if you can get to recovery mode (which does not actually alter the Jetson other than making the flash software recognize it), then you could attempt to clone the rootfs partition. Be sure to use the same release of software from JetPack/SDK Manager you flashed with for other flash operations, but basically, assuming L4T R32.x, clone is like this:
sudo ./ -r -k APP -G my_backup.img jetson-tx2 mmcblk0p1
…which produces both my_backup.img.raw (which is a quite useful “raw” file) and my_backup.img (a far less useful “sparse” file).

If cloning works, then you have a backup. If cloning does not work, then it is likely hardware failure.

While checking for errors on the connections between the TX2 UART and USB to TTL converter, I checked to see if there was voltage between the J21 5V pin 2, and the J21 GND pin 6, but there’s none, nothing when plugged in, and nothing after pressing the power button. Is this a clear indicator of hardware failure?

I suppose it is possible for an incorrect device tree to leave the power rail off, but this is rather unlikely. Odds are highly in favor of carrier board hardware failure. If you examine J21 pin 2 and compare it to the standoff of the carrier board (which should also be ground), does it still show zero volts even when pressing the power button?

I checked the voltage between J21 pin 2 and the screw of one of the standoffs and got no voltage.

This is not a guarantee, but I suspect the module is working and only the carrier board is failed. There is no way to purchase a development kit carrier board separately, but third party carrier boards will work. To use with another carrier board for extracting a clone anything will work, but if you want to boot on another carrier board you would have to also flash that device tree (the board support package). I am not sure how long the TX2 developer kit will be available for, but it will be EOL (other than maintenance) soon.

I decided to also check the J21 pin 1 3.3, and it does show some voltage, albeit not 3.3V, but a rising 0 to 0.4 volts everytime I press the power button.

Are there any devices connected? Sometimes an external device can fail in some way and bring a bus down. Be sure to check the voltages with no USB devices, no PCIe devices, no monitor, so on…and if the voltage is still low, then you have hardware failure.

After removing the devices (the TX, RX AND GND connections) now no voltage is shown in either the 5V or 3.3V pins. I guess I’ll start the RMA procedure.

Thanks a lot for the help linuxdev.

One last question, so a third party carrier board could be the solution even after the pin voltage issues?

Your guess was right linuxdev, the carrier board was the issue, I transplanted the module to a friend’s carrier board, and everything is working fine.

Any carrier board will work, but you will likely need a new board support package (mostly the BSP is a new device tree). You can clone without issue even if the carrier board changes since recovery mode has no dependency on device trees or carrier board. Thus, if your work is important, you can still get a backup of it on any carrier board before working on updating to work with the new carrier board. Do be careful to check carrier board vendor information to see if the particular release of L4T you need is supported on that carrier board (third party carrier boards lag behind the development kits for support of new L4T releases).