Problems with TX2 and Orbitty Carrier

Hello everyone, I’m having a real hard time trying to make this whole thing work, but I’ll explain myself.

I have to use this neural network with the help of the Jetson TX2, which is very convenient as the CNN offers the possibility of GPU acceleration via CUDA.

However, I’m having a lot of trouble trying to flash my Jetson; I’ve downloaded the proper version of Jetpack (3.3 if I remember it correctly) and it installs successfully on my host PC with Ubuntu, but it’s been impossible for me to get the Jetson into recovery mode.

I’ve tried lots of differents configurations so as to determine where the failure is, and I’ve already discarded malfunctioning of both power supply (right now I’m using the typical “configurable” power supply provided in most laboratories, like this one) and micro-B USB cables, as I’ve tried with a bunch of different, well working ones and it still didn’t work.

So this leaves the failure either to the dev board I’m using or the Jetson itself, provided that the USB ports on my PC aren’t trolling me. The board I’m talking about is the Orbitty Carrier, whose manual is here. In the “Force Recovery Mode” section, which seems to be a copy/paste of the instructions in the Jetson Developer Kit User Guide, I’ve followed the steps lots of times in different ways and still accomplished nothing.

I’ve tried to press power on the board while holding recovery, press reset after pressing power while holding recovery, press power during 5 seconds (so that the “hard power off” was triggered) then release it while holding recovery (all of this with power supply on beforehand) and connect the power supply while holding recovery, everything to be a complete failure. I even tried to do it with the expansion pins that the board provides, as they extend the three POWER/RESET/RECOVERY buttons, but nothing again.

So right now, I’m running out of ideas and I’d like to ask you for your help, because I’m starting to think it might be a problem with the Jetson, but I can’t think of any way to check if I’m right or not. It could also be a problem with the board and its connections to the buttons with the Jetson, but same as before, I’m not able to determine it.

What are your thoughts? Any other tests that can be run to determine the failure? Should I consider a RMA? And last but not least, do you know if it’s possible to use the SD slot offered by the Orbitty Carrier to boot the Jetson? (I don’t think so, but any ideas are welcome)

Thank you very much for your help and time

It’s quite easy to brick the USB port - I did it myself :(
Never connect / disconnect any of the cables on TX2 whilst powered up.
Even using the wrong button sequence could damage it, i believe.
I sent my dev kit back and got replacement.

Is it correct that otherwise you are able to start the board in some way (even if it doesn’t boot correctly)? The TX2 is picky about power supply delivery for a very tiny slice of time right at the moment it turns on, and I’m looking for indications as to whether the board actually runs from that supply and connector combination (some 5.5 mm connectors advertise 2.5 mm inner diameter, but are actually 2.1 mm…they work on less critical devices, but the resistance is a problem for a TX2). Often people resort to large capacitors right next to the connector.

If this is a module which was not sold originally as a dev kit then it will have absolutely no software on it and will not even appear to begin boot (although recovery mode would not be any different on a module without software).

If your host is a VM, then there is a very high chance that the USB port isn’t being passed through correctly. Is the host a VM or is it a native install?

Micro USB connectors are fragile, and a number of people have had torque on the connector cause traces to separate, so you might examine if it looks like there are cold joints or separated traces near it. Your actual steps for putting the Jetson in recovery mode seem valid if the power supply is not an issue.

If none of that is at issue, then it probably is time to attempt RMA. If you want to RMA then search for “RMA” near the top of this:
https://devtalk.nvidia.com/default/topic/793798/embedded-systems/some-jetson-web-links/

In fact, I don’t really think power supply is a problem right now. The supply is stable and provided via two wires connected directly to the source, due to the Orbity Carrier requiring that (you’ll notice the terminal block at the right-down corner in this image).

Yes, it was a module sold separately from the devkit so I didn’t expect any booting, but the host I’m using is a native install of Ubuntu 16.04 (I’ve had issues before with VMs and would rather avoid them). As for the micro-USB cables, as I said I tried a bunch of them, including one which I am certain it works, as it successfully connected an AGX Xavier in recovery mode to the host (lsusb command showed the device), so that leaves me with either the board or the Jetson to be the problem.

I’ll try checking Orbitty’s USB-OTG connections to see if there’s something wrong, but unless the problem’s there, I’ll have to try RMA.

Oh, and just to discard every other option, is the Jetson TX2 compatible with the AGX Xavier devkit? I’m assuming it’s probably not, but if it was, that could really give me the opportunity to determine whether the TX2 is the problem or not (I have access to a Xavier devkit, but only got the Orbitty Carrier for the Jetson).

Thank you very much for your help and time.

Hmmm I don’t know if the port is really bricked, but I’ll sure be following those directions. I’ll probably have to go with RMA, so I wouldn’t like to screw a new device. Thank you!

Hi Enrique, if the module still boots/works while mounted on the devkit, and it can enter Recovery mode there, then your module is OK.

If you haven’t already done so, I recommend calling or e-mailing ConnectTech Support directly, and they will get you up & running with your Orbitty.