Jetson TX2 Freezes at System Configuration Screen

Forum,

I just flashed by Jetson TX2 to R32 Rev2.3 and now my board is unresponsive after boot. ! I am unable to use the keyboard and mouse, no response from OS, and can no longer see the device via lsusb. I can see it on the local network via the wired network connection. I am also unable to SSH or access the device in any way from the host. I have attached two images. One is of the scree the Jetson freezes on, I suspect it is not frozen rather it won’t take input from most and keyboard. I also added a figure of errors on startup. They suggest the USB port is unresponsive? That makes no sense to me since I flashed it via the USB cable and micro-usb port. I would really appreciate some suggestions on how I can either get the Jetson working again or somehow reset it.

20200619_144847|500x500

I should add that I am using a PC running ubuntu 18 and flashing via the sdk manager

Is the host a VM? I am guessing not, but have to ask. Also, is this on a developer kit carrier board, or is it a third party carrier board? At the location where you flashed from on the host PC, how much disk space do you have? One way to see disk space and filesystem type:
df -H -T /where/ever/it/is/Linux_for_Tegra

Is the cable used on the micro-OTG the micro-B cable which is provided with the dev kit?

First, thank you for responding. On a Saturday even. Now to your questions. No I am not using a VM. I have been using the default for the SDK manager the last two weeks. After flashing the TX2 and having issues I uninstalled the SDK manager and removed everything then reinstalled wondering if that might help. It did not. I do not have a dev kit although ordered one which should be here by Tuesday. I am using a micro-OTG cable and prior to this flashing I could connect via SSH and lsusb would show the device. I would also connect via my local lan and a wired cable. I ended up deciding to reflash because I was running into major issues with OpenCV and read in several forums people solved their problem by reflashing. The frustrating thing is that the device boots to the desktop as shown in the photo but since it does not recognize the USB I cannot do anything. I also cannot use the micro OTG cable to connect. I can ping it via the LAN but SSH response is denied. Perhaps it did not startup either? Does that help at all?

Does ssh fail without ever offering to let you send a password? Is it correct that serial console also fails?

USB is hot plug, so is there any change if you unplug and replug the mouse/keyboard? If you are using a HUB, can you try the keyboard without HUB? Or can you try a different HUB? Is there anything connected other than mouse/keyboard/monitor/ethernet?

Did “df” show available space where you flashed from, and was it type ext4?

It does fail before password.I have not tried a serial console. Can you provide a URL otherwise ill google.

On Sat, Jun 20, 2020 at 12:22 PM linuxdev via NVIDIA Developer Forums Does ssh fail without ever offering to let you send a password? Is it correct that serial console also fails?

i tried several times disconnecting from the hub. I also tried just using the keyboard and monitor. No network cable or USB cable. Again no response but I can ping it from my laptop but nothing else. Also I could not check df on the host because I had reinstalled the OS. I have also tried a different USB cable and I am going to try a different power supply on the very slim chance their is a power issue. Do you have any other ideas? I did look into serial console but all the comments and turorials I found assume a dev board. I currently have just a jetson tx2 module although will have a new dev kit tuesday. Do you think I should attempt to use the serial console? Also are there any other steps here. For the life of me I dont see a solution. If I understand there is no way to do a “factory reset?” That your only option is using the SDK manager which seems to be off the table for me since I cannot even SSH in. Its frustrating since it clearly was flashed and it boots into the desktop but since the USB interface is not working their is no way to move forward from the GUI nor access via USB cable.

Serial console is definitely the best thing to start with. Serial console has very little dependency on a number of components both GUI and regular text and ssh logins can fail from. Serial console might allow login, and at the very least, a boot log from serial console would provide much more detail about what is really happening (and what happens just before failure).

Btw, flashing does not care whether the installed software works or not. When the Jetson is in recovery mode it becomes a custom USB device and does not boot up normally…this is by intent. A fully booted system cannot be flashed, and so your situation in no way hinders flash.

Sometimes it is as simple as the filesystem being filled. No room for temp files means it crashes and burns. Since serial console sometimes works when all else fails something like insufficient space could be a simple fix. We have to see the serial console boot log though, and we have to find out if you are able to log in via serial console.

Serial console information:
http://www.jetsonhacks.com/2017/03/24/serial-console-nvidia-jetson-tx2/

Thank you for the info. Is there a way to access the serial port without the dev board? I also should have mentioned their is a Leopard camera attached to this board. Pretty sure that did not effect anything but its worth noting i think.

Hi,

Actually we had lots of issue that have similar symptom as yours. Unfortunately, we cannot get the actual cause of this issue.

We need to check

  1. Is this a fresh out-of-box jetson TX2? Or you have flashed it before?

  2. Could you remove the ethernet cable to reboot again? Some forum users suspect this is the cause.

  3. We still need the serial console log. What kind of carrier board are you using? Does it offer a UART pin to dump serial log?

  4. Any other I/O connected on it?

See what @WayneWWW said. Do know that most vendors provide a micro-OTG USB port, and that this should work for any kind of flash of a TX2. Serial console itself will depend on the particular board, and I have no way to know what pins might provide that function on third party carrier board. All I am able to say is that it is highly likely there are some header pins available for this in their documentation.

Thank you for your response. Here are my answers to your questions.

1: No this is not fresh out of the box. It has been flashed before.
2: I have tried rebooting without the network cable, without any USB connections, without the hub and keyboard installed directly, and numerous other variations. The same issue remains.
3: i have the TX2 module. Looking at the pinout schematic I am not sure what to do to use the serial interface but it does look like one is there. Are their any instructions on how to do this for a TX2 module? I am supposed to be getting a dev kit tomorrow. I will look to see if i can mount my current module on the board.The current board also has a Leopard camera mounted to that. Not sure if that is a possible fault.
4: The only other connection has been the monitor via HDMI, i have not thought to try booting up without the monitor. I will try that.

I am a little confused. There is no 3rd party board. Just Jetson TX2 module. I did look at the pinot schematic for the board and its looks like there are several UART pins. Not being a EE or someone versed in electronics though I am not sure what does what and where to begin. Ill do some more googling on that but if you know of a link to instructions on how to do it with a NVIDIA Jetson TX2 module I would be grateful. Thank you for your assistance so far.

About:

Every module mandates some sort of carrier board, either from the development kit carrier board or some other board (the first image of that URL is a module, the second image is a module mounted to a development kit carrier board), so I may just be wording things badly and causing confusion. The module all by itself is not intended to flash or boot. If the module is bolted down to a circuit board with connectors, then you have a carrier board.

Some carrier boards route different UARTs in different ways (or leave some UARTs unconnected). If your module is mounted to another board, then you have a carrier board, and it would be important to know what the specific carrier is when trying to debug (different carriers require different firmware/device trees). Do you have the development kit? Or a lone module? Procedures vary dramatically depending on the carrier board, and I suspect that you have a development kit (if we make that assumption and it isn’t correct, then figuring it out will be rather difficult). This earlier statement is why I asked about a third party carrier board:

1 Like

I currently only have a module. It was provided by a client who wants me to add some machine vision software to it. I am receiving a new developers kit tomorrow but it would be very good to get this current module working. I am assuming I can plug it into the developer meant board when it comes BUT it currently has a Leopard camera connected to the bottom of the board. I hope its ok but I have added some pictures that show you what I currently working with.

Thank you

The board this bolts to is your carrier board, and is definitely not the development kit carrier board. This implies you need firmware specific to that board for boot to work. Typically this means taking the flash software used for development kit flash, and copying some custom files in place (adding or replacing some of the boot related content).

Do you have a model number or reference to the part of the PCB with the HDMI/USB/ethernet connectors? If you do, then you’ll be able to search from that manufacturer for firmware (which will be tied to a particular L4T/JetPack/SDK Manager release).

Ill look other wise I have to reach out to the people who sent it over. Thank you for pointing this out. I am new to this and appreciate the education.

this is it. the model and rev were on the back. https://www.leopardimaging.com/uploads/LI-TX1-CB_datasheet.pdf

i think i see were a UART connection is for serial interface which is J17 but again i am not a hardware person so I am not sure.

If you have devkit, then there is already a pinout. All you need to do is connect the usb-ttl cable to it.

https://www.jetsonhacks.com/2017/03/24/serial-console-nvidia-jetson-tx2/

Actually, I think if you re-flash your board again with jetpack4.4, this issue would be gone. If I were you, I will re-flash it with latest release before dumping out the log.

1 Like

Wayne,

I learned that the module I have is mounted on a Leopard Image board https://www.leopardimaging.com/uploads/LI-TX1-CB_datasheet.pdf. I am going to make some usb-ttl serial cables tomorrow and see if I can access the board that way. If I cannot then Ill try to unmount the model and remount it on the dev kit board. Does that sound like a reasonable plan