Jetson TX2 will not turn on after power supply swap

I am using a Jetson TX2 for a robotics application. I have used it with both the robot battery bank (15V) and the wall plug that came with the Jetson. Today, I unplugged the Jetson from wall power and switched it to battery power, and it would not turn on. After I switched it back to wall power, it still doesn’t turn on. It has worked with both power supplies just fine in the past.

The current state of the Jetson is that a red light will come on for the duration the power button is pressed, but will turn off again when it is released. It does not turn on. I am looking for the simplest solution possible here, since the robot getting up and running again is somewhat time sensitive. Any help is greatly appreciated!

hello kyle-lastine,

please review [Figure 6. Power Block Diagram] via Jetson TX2 Series OEM Product Design Guide.
could you please setup serial console and gather the bootloader messages while the failure happened.

You might also mention if the LEDs which normally light are lit.

They are not, save for the one red one. Normally, several others would come on and stay on after startup.

The one with the LED working should be able to provide a serial console boot log, which is what would help a lot. So far as the ones without LED, 15V should be ok on a dev kit, but it seems suspicious that perhaps the carrier board has failed on those. In theory, if you have one working carrier board, then you should be able to plug any module into that board and clone it if it has valuable data on it. Most of the time (when hardware failure is involved) it is only the carrier board which fails.

I’m not experienced enough with the Jetson to know exactly what this means. Is there some hardware component on the Jetson I could replace in the event that it was fried? What possible problems could be incurred by supplying an unintentionally high voltage if that is what happened?

I wouldn’t recommend this normally (especially without experience working on circuit boards), but if you have several TX2s available, and one can maintain the LEDs as lit, then probably that carrier board is working. The actual module is held to the carrier board by four screws (I’m assuming an actual TX2 dev kit, not the TX2 NX, which has two screws). Typically you can carefully remove a module from one carrier board and mount it on another carrier board. It is the carrier board which has the power delivery components, and if one is bad, then a good module taken from a bad carrier board and placed on a good carrier board should work again.

I couldn’t tell you which component would need replacing on the carrier board, but I can absolutely guarantee that you don’t want to mess with a surface mount component without some experience using a rework station (not just a soldering iron).

Unfortunately you cannot purchase just the carrier board. You can purchase third party carrier boards, but these will require flashing to be fully functional under a new carrier board. It is reasonable that some sort of power surge caused a carrier board failure, and that is what I think is the most common cause of hardware failure…the power delivery portion of the carrier board.