Sdk manager

I installed sdkmanager on wsl ubuntu but everytime I run a command I receive this error:

Error: EACCES: permission denied, mkdir ‘/home/janice/nvidia’

Please advise.

Hi user152681,

It looks like SDKM doesn’t have the permission to create the “nvidia” sub folder under your home directory. Are you able to create the directory /home/janice/nvidia manually?

No I cant. Any ideas on how to fix that? I know how to can change to the permissions one folder at a time but that doesnt really help w running sdkmanager. Also sdkmanager doesnt work with sudo command

First, WSL2 won’t work without additional knowledge (and I think that might be a significant learning curve). Also, the filesystem would have to be formatted as ext4, not NTFS or VFAT. Permissions have no chance of succeeding without a Linux filesystem type.

What additional knowledge? I can partition a drive with ext4 if that is all that is required.

The kernel needs to support loopback, that’s the more arcane knowledge. I don’t personally know how to add that in. The more common problem with all VMs (loopback is an issue specific to WSL2) is that USB needs to be set up to always go to the VM. During flash the USB disconnects and reconnects, and if not correct, flash will start and then fail in the middle. And yes, ext4 is mandatory; without it flash seems to work, but the install will not work correctly.

What is the error message when you try to manually create /home/janice/nvidia directory? This is a general Linux issue, not an SDK Manager specific issue. You could probably get a quicker answer by googling the question.

Is there a general fix to setting the usb to always be attached to linux in wsl? I think am experiencing the problem you described with the flash ending abruptly and then i notice the usb drive is no longer attached.

I can’t answer that. Every VM has its own instructions on doing so. Microsoft produces WSL2, so you’d have to use their documents. As soon as you get to some step which requires loopback, you’ll have to figure that out too (generating images requires loopback).

I have not tried this yet, but it should be possible to flash Jetson from WSL2. See:
How to flash NVIDIA Jetson devices with Balena using WSL2 and Docker - DEV Community

Looks like you will have to run usbipd with additional arguments

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.