JetPack 4.2 sdk Manager needs root by default, how to tell it to use a different directory

Hey all,

When I use the JetPack 4.2 to reflash my Xavier the sdk manager tries to access and create directories in /tmp, /usr, /bin which my super user level (work computer) does not have access to, and then subsequently fails because it can’t right files to the new directories. How do I tell it to use the local directory to write files to.

example bugs:

14:44:46 ERROR : File System and OS : tar: bin: Cannot mkdir
14:44:46 ERROR : File System and OS : : Permission denied
14:44:46 ERROR : File System and OS :
14:44:46 ERROR : File System and OS : tar: bin: Cannot mkdir: Permission denied
14:44:46 ERROR : File System and OS : tar: bin/su: Cannot open: No such file or directory
14:44:46 ERROR : File System and OS : tar: bin: Cannot mkdir: Permission denied
14:44:46 ERROR : File System and OS : tar: bin/systemctl: Cannot open: No such file or directory
14:44:46 ERROR : File System and OS : tar: bin: Cannot mkdir: Permission denied
14:44:46 ERROR : File System and OS : tar: bin/mktemp: Cannot open: No such file or directory
14:44:46 ERROR : File System and OS : tar: bin: Cannot mkdir: Permission denied
14:44:46 ERROR : File System and OS : tar: bin/fusermount: Cannot open
14:44:46 ERROR : File System and OS : : No such file or directory
14:45:05 ERROR : File System and OS : tar: lib: Cannot mkdir: Permission denied
14:45:05 ERROR : File System and OS : tar: lib: Cannot mkdir: Permission denied
14:45:05 ERROR : File System and OS : tar: lib/firmware/ipw2100-1.3.fw: Cannot open: No such file or directory

thanks,
Sam

Needing root access is an absolute requirement for the step of creating the flash image. The image itself is an exact copy of an entire file system. This includes device special files, users and their passwords (of which most are different than those on the local system), suid root programs, so on. Only root can do this, no other user is allowed that power.

The image becomes “bootloader/system.img”, and this is just binary data, and so possibly if you used the “-r” option to flash.sh to “reuse” the existing image, and if you edited the flash.sh script to not require root, then possibly you could flash this. The image is just binary data once created.

Dear all,

I ran Nvidia SDK Manager on my ubuntu 18.04 host and ask it to install tools. Where are they, which directory?

JetPack 4.2 components:
L4T R32.1 (K4.9)
Ubuntu 18.04 LTS aarch64
CUDA 10.0 --> /usr/local/cuda
cuDNN 7.3.1
TensorRT 5.0.6
VisionWorks 1.6 --> /usr/share/visionwork
OpenCV 3.3.1

How to install nvidia-smi?
In my python 3.6.7, it gives error when I try:
import cv2

Thank you very much in advance.

Warmest Regards,
Suryadi

The GPU in embedded systems is integrated directly to the memory controller. Desktop PCs go through PCI. Nvidia-smi requires PCI, and thus cannot run on a Jetson (any utility requiring the PCIe card will not work).

Dear linuxdev,

My desktop is OMEN by HP Desktop PC - 870-281jp https://support.hp.com/id-en/document/c05391540

Video Graphics

NVIDIA GeForce GTX 1080
Form Factor: Full-height PCB with ATX dual slot bracket
Dimensions: 10 Layer / (4.4 in x 10.5 in)
Rear I/O connectors: Dual-Link DVI-D + HDMI + 3 DisplayPort
Maximum resolution:
DisplayPort resolution: 5120 x 3200 x 24 bpp @ 60 Hz / 7680 x 4320 @ 60 Hz YUV 420 8 bit
DVI resolution: 2560 x 1600 x 24 bpp @ 60 Hz (Dual Link)
HDMI resolution: 4096 x 2160 x 24 bpp @ 60 Hz ( HDMI 2.0)
NOTE: Not all ports support the highest resolutions.
Memory size: 8 GB (256-bit)
Memory type: GDDR5X
Total power consumption: 180 W
Supports up to four displays at the same time with independent resolutions up to the maximum.
Engine clock: 1067 MHz (Base) / 1733 MHz (Boost)
Memory clock: 5005 MHz (10 Gbps)
Cooling: Active fan-sink with 4 pin fan control
External power cable: One 2x4 (8 pin)
DirectX: DX12
PCIe: PCIe x16 Gen 3

I think the GTX1080 GPU is through PCI express slot.

Thank you very much in advance.

Warmest Regards,
Suryadi

Yes, that should work with nvidia-smi (it is the Jetson which cannot use that). If the package were installed, then it should be in “/usr/bin/nvidia-smi”. I use a Fedora host most of the time, and so I manually install the NVIDIA video driver using the “.run” package and find the “nvidia-smi” at the location just mentioned.

Do you see it from “which nvidia-smi”? The location might differ on Ubuntu, but it won’t be in the “/usr/local”. You might try “sudo updatedb” (if it is installed), and then “locate nvidia-smi”.