Set obj_meta.rect_params.border_color,bbox disappear

Please provide complete information as applicable to your setup.

**• Hardware Platform (Jetson / GPU)**Jetson Xavier NX
• DeepStream Version6.0.1
**• JetPack Version (valid for Jetson only)**4.6.2
• TensorRT Version8.2.1.8
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

no_rect
when I set it

when I comment out

Can you check the behavior of example program (for example deepstream_python_apps/deepstream_test_1.py at master · NVIDIA-AI-IOT/deepstream_python_apps · GitHub)

obj_meta.rect_params.border_color.set(0.0, 0.0, 1.0, 0.0)

I checked this program on Nano with JP4.6.2 + DS6.0.1 and found that it’s working well, not sure if there is other code in your program that has such impact.

I check this program,got the same result@yingliu

This is the log
log.txt (4.5 KB)

1

Could you try to set the paras to (0.0, 1.0, 0.0, 1.0)?

I try, it doesn’t work.

You can try the method below to verify the problem:
1.use our demo code: deepstream_test_1.py
2.Just change the obj_meta.rect_params.border_color.set(0.0, 0.0, 1.0, 0.0) to obj_meta.rect_params.border_color.set(0.0, 0.0, 1.0, 1.0)
I run it in my Xaviar, it works well.

Yes, that’s what I did, but it didn’t work in my code or deepstream-test1. And no matter what value I change in parentheses, there’s no bounding box.

But when I comment out

obj_meta.rect_params.border_color.set()

I get red bounding boxes.

The same code works well on jetpack4.6 and 4.6.1, and I can also change the color of the bounding box with obj_meta.rect_params.border_color.set()
Processing: comment-out-obj_meta.png…

There may be some problems with your env, you can try to update to our latest version. We suggest you install it according to the following dependencies.
https://docs.nvidia.com/metropolis/deepstream/dev-guide/text/DS_Quickstart.html?highlight=compatibility#platform-and-os-compatibility

I solved it. It’s my env problem. Thank you very much

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.