[SOLVED, solution included] CUDA Compatibility issue with High Sierra 10.13.4

(Temporary SOLVED)

Hi,

I am seeking help with CUDA running on macOS High Sierra 10.13.4. After searching all the methods I could find on internet and in the forum, I was still not able to get CUDA up-and-running on my Macbook Pro, was wondering if anybody having the same issue or solution to it?

My device is equipped with GeForce GT 750M.

Thank you!

I am having the same issue with macOS High Sierra 10.13.4 on a MacBookPro Mid-2014, NVIDIA GeForce GT 750M 2048 MB and an Intel Iris Pro 1536 MB

After some digging around I found this link at insanelymac.com that points to an NVIDIA Web Driver that works for 10.13.4
Reference » https://www.insanelymac.com/forum/forums/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-03302018/
Direct Download » https://images.nvidia.com/mac/pkg/387/WebDriver-387.10.10.10.30.103.pkg

^ The Web Driver installed without any issues; restarted and now I have the menu bar selector for which driver to use. The System Settings: NVIDIA Driver Manager, checking for updates says there are none.

So, now I am having an issue with finding CUDA drivers that work with 10.13.4 – I currently have the ominous red Update Required

I even tried turning off » System Settings: Energy Saver: Automatic graphics switching

Current Drivers:
CUDA Driver Version: 387.128
GPU Driver Version: 387.10.10.10.30.103

Hey,

I just found a work-around for it, and it works(but a bit unstable). So here are the steps:

Temporary Solution to Enable CUDA on High Sierra 10.13.4

Proceed with caution, as you may experience kernel panic and lead to an unstable OS.

  1. Install the Nvidia Web Driver by executing this code in Terminal (thanks to Benjamin Dobell):
    bash <(curl -s https://raw.githubusercontent.com/Benjamin-Dobell/nvidia-update/master/nvidia-update.sh)

Github repository can be found here:https://github.com/Benjamin-Dobell/nvidia-update

What this step does is basically install the “best” driver for your Mac, not the latest one, but the one released in Dec, 2017 (378.10.10.10.25.106)

  1. Install the CUDA driver (387.99, not the latest!):
    http://www.nvidia.com/object/macosx-cuda-387.99-driver.html

(I realized since the Web driver we’re using is released in Dec, 2017, it is reasonable to also install the CUDA driver released in Dec, 2017.)

  1. Done!

I am now able to render my After Effects composition using CUDA without having issue now. But I will expect kernel panic and it is reasonable that this solution is not official, I’m ok and happy with it!

To test if CUDA is really functioning on your OS, do search CUDA-Z. If you have Adobe Products install such as Pr and AE, you should be able to select Mercury Playback (CUDA) in the render/preview option (render option can be found in Adobe Media Encoder).

Again this is not an official way to do it but at least it works. I’m frustrated with all this incompatibility issue on Mac laptop with Nvidia nowadays, and
frankly speaking, no one should be blamed but hope these companies think more about their customers/clients.

Wow, fantastic information @kevenlrx, thank you for sharing!

Have you had a kernel panic yet??

Hi Auguststurm,

I did have kernel panic twice, but don’t panic! I was experiencing it when I run Premiere Pro right after the installation of CUDA (I did not restart after CUDA installation, which I should). After restart, I run After Effects and also have a kernel panic. Did not have any other kernel panic since then.

Now everything looks normal to me, I rendered couple projects without having issues. To me it feels like the System is “adapting” the legacy driver and functioning “properly”. I’m ok and satisfy with it now.

I will keep you posted if I have any issue.

Hey kevenlrx,

I finally did a TimeMachine backup of the new system… Tried to run the bash script and it threw an error:

curl: (60) SSL certificate problem: unable to get local issuer certificate
More details here: https://curl.haxx.se/docs/sslcerts.html
curl performs SSL certificate verification by default, using a "bundle" of Certificate Authority (CA) public keys (CA certs). If the default bundle file isn't adequate, you can specify an alternate file using the --cacert option.
If this HTTPS server uses a certificate signed by a CA represented in the bundle, the certificate verification probably failed due to a problem with the certificate (it might be expired, or the name might not match the domain name in the URL).
<b>If you'd like to turn off curl's verification of the certificate, use the -k (or --insecure) option.</b>

Question: Did you have to run it the -k or --insecure option??

Hey Auguststurm,

I did not. I just simply pasted the code to the terminal and was able to run. Personally speaking I think it is ok to run with -k, because I trust the author.

His Github repository is here:

Thank you @kevenlrx!

I went from from CPU: 5:40.15 to GPU 4:16.90, in Blender 2.79b with a cycles rendering!

You saved me time, well done! :-)

hello, this is not normal, we must make a petition against apple of this boycot of cuda, we lose the power of our macbook pro. Do not let us do it !!!

No problem, Auguststurm!

I just heard that by 2020 Tim Cook plans on ditching Intel on new Macs… I still have this on my 2012 Mac Pro…GPU Driver Version: 387.10.10.10.30.103, CUDA Driver Version: 387.128 macOS 10.13.4 Very sad I can’t use Redshift; The CUDA Driver currently installed on your system needs to be updated. Please update to the latest CUDA Driver to ensure your CUDA-enabled applications continue to function properly.

Not sure if I want to use the method stated above, maybe give Nvidia a bit more time. Or I just start using Redshift in Windoz… Runs awesome on this Mac Pro with Bill’s telemetry and auto updates disabled…

Hello,

Personally speaking, if you’re not in a rush, I will recommend you wait for the official updates.

I have performed the above stated steps and was able to enable CUDA on my Macbook Pro (Mid-2014), except experiencing kernel panic twice right after the CUDA installation (I have not encountered any other issue since then). My CUDA does not complain and ask for updates.

Additionally, I performed some renders on VFX-intense projects also not experiencing any issue.

Hope this may help resolving your issue.

The question is above all, is there going to be an official resolution of the problem?

Everyone save this script. It fixed this issue in minutes. Run in terminal. It will search the web for the right driver and install. You will have to enter your password after it runs and then system restart once it tells you. I spent days trying to figure it out and my homie sent me this. Fixed my issues immediately.

Copy and paste this into terminal:

bash <(curl -s https://raw.githubusercontent.com/Benjamin-Dobell/nvidia-update/master/nvidia-update.sh)