CUDA still shows as "Update Required" after installing latest package for macOS

It seems that CUDA 8.0.53 is broken after updating macOS Sierra to 10.12.2.

Here is a screenshot:

http://imgur.com/1yepO6x

Interestingly, I redownloaded a supposed cuda_8.0.55_mac.dmg from https://developer.nvidia.com/cuda-downloads, installed it, but still end up seeing version 8.0.53 in the System Preferences.

Anybody knows what’s going on?

+1, same issue.

Did you try the network or the local version? Did you check in the the package?

Both (local and network).
Also, I tried to uninstall before the cuda’s driver and then reinstall it with the last package (8.0.55 https://developer.nvidia.com/cuda-downloads) but the version installed is always 8.0.53 (with the macOS alert “update required”).

Thank you! Did you check the version in the package? in /Library/Frameworks/? Guess we have to sit out till Nvidia releases a working version

8.0.53, also after reinstalled all with the last package (local/network)

I checked, in that file is the same version framework as in the official driver so NOT a new one but the same 8.0.53 not a 8.0.55

In this page the last version is still 8.0.53 (not compatible with macOS 10.12.2):
http://www.nvidia.com/object/mac-driver-archive.html

In this page instead 8.0.55:
http://www.nvidia.com/object/mac-driver-archive.html

AAAMike also no luck with the network version, that one should download from a site and not use the included one (that is the case with the local version which is the wrong one)??

Despite the message, CUDA is working and enabled on my system in Premiere Pro

I confirm this problem.

I’m experiencing the same problem, after updating CUDA to version 8.0.53, the CUDA preferences panel is still asking for an update (on macOS Sierra 10.12.2).

BTW, i’m not seeing a version 8.0.55 on this page:
http://www.nvidia.com/object/mac-driver-archive.html

The latest drive on that page is:
CUDA Mac Driver
Latest Version: CUDA 8.0.53 driver for MAC
Release Date: 11/22/2016

Where did you find version 8.0.55?

https://developer.nvidia.com/cuda-downloads points to a page where a CUDA toolkit with 1.3 GB - i think, i’m just needing the driver, not a toolkit…

Hi Guys,
same issue for me…
i have reinstalled the old version found on http://www.nvidia.com/object/mac-driver-archive.html
but require always the update.

if someone resolve the problem, please tell to everyone.

Thanks.

Same issue in Mac OS X 10.11 (El Capitan).

After installing Mac OS X 10.11.6 Security Update 2016-003, Nvidia Web Driver requires update.

After installing Nvidia Web Driver 346.03.15f05, CUDA Driver 8.0.53 requires update.

No CUDA Driver update is currently available.

Nvidia, please advise asap.

is available the new driver 8.0.57… problem fixed, not more “update required”.

I updated to 8.0.57 and still get “update required”…anyone else is having this issue or anyone knows how to fix it? :(

I can’t confirm this. I have been experiencing that problem with version 8.0.53, but with version 8.0.57 it was solved (macOS Sierra 10.12.2).

I tried uninstalling 8.0.57 and installing again and same error. Sharing a pic :(http://i67.tinypic.com/2h3pibl.jpg. I have MacOS Sierra 10.12.2

I’m seeing this on 10.11.6

I’ve took to removing the com.nvidia.CUDASoftwareUpdate.plist Launch Agent to get around this