Update driver on Mac OS X 10.11.6

This is driving me nuts. Why is it so damn hard to update the CUDA driver for my computer? I have an older iMac 14,2
Still Running OS X 10.11.6 El Capitan with an NVIDIA GeForce GTX 780M.
Im getting the dread “update required, No update available” message

The Drivers below may well be wrong , but how the hell am I supposed to find what’s right.

CUDA Driver Version: 418.163
GPU Driver Version: 346.03.15f10

well it seems that after i wrote all that i found a newer gpu driver for you
try this first as this alone most likely will fix your problem
but i will leave everything i wrote for future references

https://www.nvidia.com/content/DriverDownload-March2009/confirmation.php?url=/Mac/Quadro_Certified/346.03.15f16/WebDriver-346.03.15f16.pkg&lang=us&type=GeForce

this is driver version
346.03.15f16

follow this instructions so you find the drivers in the future

go here

https://www.nvidia.com/Download/index.aspx?lang=en-us

product type = quadro
product series = quadro series
product = quadro k5000 for mac
operating system = show all operating systems

now mac os show up

choose or select you mac os version
now simply hit search

like i said this most likely will fix your problem

message delete, method no longer need it

message delete, method no longer need it

message delete, method no longer need it

I appreciate your efforts to help a great deal. I confess that my understanding of this level of tech is virtually nil. However I can follow directions and I think I tried exactly what you said to alter the Cuda Frameworks file. I was able to accomplish what you directed and I think I did it correctly , though I used

libcuda_346.03.15f10_mercury.dylib

and

346.03.15f10
346.03.15f10

as I had no idea how to look for any newer version of the dylib file. I have no idea what that even is.

Anyway, unfortunately nothing changed at all. I still got the missing driver notice and I am still unable to open Resolve with the same error message - " no Cuda found."

Frankly I’m sick of it all and decided to just buy a new faster computer ( used actually) a 2017 iMac with a Radeon Pro 580. The weird thing is I was able to open Resolve not to long ago and haven’t upgraded my operating system since then. I have no idea what would have changed.
Well… So much for Nvidia. I have no idea whether this is Apple’s fault or Nvidia’s but this crap is ridiculous and deeply unfair to those who bought the equipment from both of them. Maybe next year Apple will break ranks with AMD and I’ll be screwed again.

Thanks for trying.

Lenny

hi i understand, there is no point now
but did you tried the latest driver from the first post?

346.03.15f16

anyway like i said there is no point now since you already have another computer
the reason why it didn’t work is because maybe you did something wrong
it happens most of the time at the first try
maybe i missed a step some where since i’m working trying to remember
which is also possible

if i would it have my computer running mac os then i would it have fixed the file for you
but anyway is already inevitable, that was the last CUDA update from nvidia and if you want to upgrade to a newer os then you only have one choice , which is AMD

yes the whole situation sucks big time but it is what it is

anyway enjoy your new system
regards

hi sorry i came back but i think i finally figured out the puzzle
with the latest web driver for 10.11.6 you didn’t had to modified the CUDA file
the fix was only for the old version of your web driver
but since i found the update then that update most likely had the new string
all you had to do was install the latest driver

anyway sorry i came back and know you got another pc
but i just want to explain what might happen and clear up all the confusion

so to fix everything , this is what you need to do

download the latest web driver for 10.11.6

http://us.download.nvidia.com/Mac/Quadro_Certified/346.03.15f16/WebDriver-346.03.15f16.pkg

and reinstall the latest CUDA for 10.11.6

http://us.download.nvidia.com/Mac/Quadro_Certified/8.0.90/cudadriver-8.0.90-macos.dmg

which is version 8 , i’m not sure if the other “newer” versions of CUDA works on El Capitan

the version of CUDA you had installed on your system is for 10.13 = High Sierra

not sure maybe it might still work but the version of CUDA for HS is CUDA version 10
while the CUDA version for EC is version 8

anyway if version 8 doesn’t work for you then try this version which is the latest one

http://us.download.nvidia.com/Mac/cuda_418/cudadriver_418.163_macos.dmg

but i think that’s what happened , you installed the wrong version of CUDA in your system

version 10 which is for High Sierra

yes you had the latest one but that was the latest one for HS not for EC
you had to install the latest one but for EC

you don’t have to do the manual fix
i wrote that before i figured out what happened
but since i wrote it
i left there as an example for others that might need that fix in the future

simply download the 2 files from the link above and install them and it should work right away
the problem was that you had an older version of web drivers with the wrong version of CUDA

try it when you get a chance and you see that it will work
if it doesn’t work then i will not bother you any more

peace

Wow. I did almost what you said and it worked on El Capitan

First I downloaded then installed as you instructed:

the latest web driver for 10.11.6
http://us.download.nvidia.com/Mac/Quadro_Certified/346.03.15f16/WebDriver-346.03.15f16.pkg

But when I tried to install:

the latest CUDA for 10.11.6

http://us.download.nvidia.com/Mac/Quadro_Certified/8.0.90/cudadriver-8.0.90-macos.dmg

The installer told me I needed OS 10.11.6 ( which I was running) as if I wasn’t running it and it would not install.

However in screwing around on my own earlier I somewhere came across a bunch of other Web browser drivers and I tried one of those for the hell of it :
WebDriver-346.03.15f10.pkg

Amazingly -That worked and the error message is gone and I can open Resolve.

So now the Cuda info window says I have :
CUDA Driver Version: 8.0.90
GPU Driver Version: 10.11.14 (346.03.15f10)

(odd since I am running OS10.11.6 but what the hell it works!

That’s wonderful and I can’t thank you enough for your persistence. Even though I am getting a new computer I may sometimes need tot the old one for a few days and still need to be able to work in El Capitan for Final Cut Pro 7. Also I hope to eventually sell my current iMAC and don’t think it will have much value with an error message popping up immediately.

I do have a few more questions :

After I set up my alt boot drive for El Capitan I was hoping to update my current iMac (2013) to High Sierra.
It sounds like you are saying that the changes I made to the Library yesterday should work in High Sierra - is that correct?

Is there also an easier way to do it just using installers like I just did? That’s so much simpler and fool proof.

The next question is how far can I update the OS on this computer and still use the NVIDIA GeForce GTX 780M?
Can I go beyond High Sierra?
If so what drivers will I need for the most recent OS I can install?

I mainly want to know this so I can be honest to anyone who might want to buy the computer.

Thanks you again . You’ve been a wonderful help. I’m in awe!

Lenny

good to hear that is finally working

so you went back to your web driver version 346.03.15f10

if is working then don’t worry leave it like that

but i’m sure the update 346.03.15f16 will also work

i figure out the whole thing, the problem is that i’m not running mac os and that make things a bit harder for me

but i do have good memory and i remember things

so then i remember about the CUDA version

so that was the problem you had the latest CUDA but that version was for High Sierra

basically you went a bit too high and jumped the last CUDA that is supported by your OS
i also imagined, fix the error just in case you want to sell the system

anyway about your questions
if you plan on using CUDA then the highest you can go is High Sierra
you can install Mojave or even Catalina in your system but you won’t have any CUDA support
also no web drivers in Mojave and Catalina but honestly there are not need it
because the card works fine with the native driver
so is up to you there what you want to do based on the apps you use

if you have any more question please feel free to ask
ignore the manual method , you don’t need that
all you need is installers as long as you choose the right ones then everything should work just fine

so one last time to make sure i explain good
High Sierra has web driver and CUDA support
Mojave and Catalina no CUDA support no WEB Driver support
but the card works with the native driver, the problem that most people have with that is the lack of CUDA support

specially if you do some work that requires CUDA to accelerate the workflow

best of luck

edit
i deleted the manual method just to simplify everything, i don’t want to confuse or complicate things

if you update your os , then you will have to also update your CUDA and web driver again
because the one you have installed in your system are for EC 10.11.6
every web driver installer have a string check that verifies the os version that you are running and if you have a diferent os then they will not install and give you an error

this os is not supported blah blah

the point is that the installer look for the system build version
and if they don’t match then it doesn’t install

THAT IS DONE TO AVOID INSTALLING THE WRONG VERSION OF WEB DRIVERS

the other scenario is the one you are asking or describing
you already have CUDA and web drivers installed for EC 10.11.6
but if you update then after you login to , let’s say to High sierra for example
then you will get 2 messages
that you web drivers are not compatible with the current version of mac os
and also CUDA will stopped working because the driver is not design for that OS

simply uninstall both CUDA and WEB DRIVERS before updating
then after you finished updating then install the right versions for High Sierra
these are the latest version of CUDA and web drivers for High Sierra

http://us.download.nvidia.com/Mac/Quadro_Certified/387.10.10.10.40.133/WebDriver-387.10.10.10.40.133.pkg

well if i’m not mistaking then this should be the CUDA driver

http://us.download.nvidia.com/Mac/cuda_418/cudadriver_418.163_macos.dmg

also you can skip this if you plan to update to Catalina

maybe you need CUDA and Catalina might not be the one for you because you might need CUDA
but if you plan on selling that computer it might be better to sell it with the latest os installed
maybe the person you sell it to doesn’t need or use CUDA

Jirin,

I’m in the process of upgrading my whole system and a new computer and it turns out now that what I need too do is get the drivers for Sierra , not High Sierra. Can you point me to the correct drivers for that OS?

hi sorry for the late reply
i did came back a few times but i saw no replies
so i figured that you were done
anyway this is for sierra

make sure to get the right version of sierra as this driver won’t work with any other version of sierra

this should be for sierra 10.12.6 build number 16G2136

http://us.download.nvidia.com/Mac/Quadro_Certified/378.05.05.25f19/WebDriver-378.05.05.25f19.pkg

i will come back in a few days

if you are not sure, simply install sierra and post your build number and i will get the right drivers for you
regards

Thanks Jiren,
I am set. That works great for Sierra and I’m now able to use my Nvidia Card on either Sierra or High Sierra.
Thanks so much for al;l your help.

Lenny

good to hear
best of luck to you Lenny
it’s been a pleassure

Antonio