Cuba 8.0RC installation problem on El Capitan (Macbook Pro A1398)

My Macbook Pro (A1398) using OSX 10.11.5 (and Xcode 7.3) has dedicated graphics card (Geforce GT650M) driver problem with CUDA.
I installed Caffe/CUDA, my dedicated graphics card (Geforce GT650M) driver became corrupt (seen via Console).
Installing Nvidia web drivers (WebDriver-346.03.10f02.dmg, WebDriver-346.03.10f01.dmg, WebDriver-346.03.10b01.dmg) with CUDA drivers (cudadriver-7.5.29-macos.dmg), and CUDA toolkits (cuda_8.0.29_mac.dmg and cuda_7.5.27_mac.dmg) is hit and miss so far.

I have already spent two days to get it working properly, using different combination and permutation of CUDA and Driver versions.
I downloaded Nvidia web drivers but they only worked/failed randomly when combined with CUDA drivers/toolkit.
Only the internal graphics card Intel Graphics 4000 is working consistently BUT it sadly cannot be used for CUDA.

I cleaned the system (by removing all nvidia drivers and cuda) while reinstalling in different combinations, yet hit/miss remains.
Sometimes it worked, that I was able to test CUDA samples and other times it worked but the notebook would freeze randomly.
I have now cleaned the system again and reverted back to “stock Apple GPU driver” by installing an El Capitan update.
So with it the vanilla state (i.e. Nvidia drivers and CUDA removed) of both dedicated/internal GPU working, am left wondering:

Is it that CUDA cannot work with Apple's drivers for my GPU.
Why are the Nvidia drivers useless.
Why does CUDA 8.0RC always update my cud driver to 8.x.x from 7.5.29.
Why does CUDA dashboard say cud driver update is required despite that "it already updated 7.5.29" to "8.x.x" by itself.
Is the Xcode version 6 limitations the issue with CUDA 7.5.27 
Why is CUDA 8.0RC asking for cuda driver which does not exist.

What am I doing wrong.
Suggestions appreciated.

A 346.xx driver won’t work with CUDA 8. It’s not clear if you are trying to install CUDA 8RC or CUDA 7.5

Pick one. Then follow the instructions in the appropriate install guide. The CUDA 7.5 install guide is here:

http://docs.nvidia.com/cuda/cuda-installation-guide-mac-os-x/index.html#abstract

Since you have OSX 10.11 and Xcode 7.3, it may be better to go with CUDA 8RC.

Follow the install guide for that, which is available on the mac after you run the installer. Or it is available from the developer site here:

http://developer.download.nvidia.com/compute/cuda/8.0/secure/rc1/docs/sidebar/CUDA_Installation_Guide_Mac.pdf

CUDA 8 will require a newer driver than 346.xx. Again, follow the install guide. And yes, CUDA 8 will update your CUDA driver from 7.5.x to 8.x That is expected behavior.

@txbob Thanks for the response …

  • noted about driver
    • installed “both” CUDA 8RC and CUDA 7.5 separately multiple times with (nvidia drivers or standalone cudadrivers)
    • even attempted CUDA 8RC toolkit install while telling it not to install its own cuda-driver (to see if it solves GPU issue)
    • only remember succeeding with CUDA 8RC (hence why I said I tested cuda simulation samples e.g. ocean, fluid, particles)
    • even the CUDA 8RC did not last long as the GPU became disabled (hence the installation breaks) once I restart the rMBP
    • following instruction/guides was how I knew that CUDA 7.5 does not support Xcode 7.3 - hence my later focus on CUDA 8.0RC
    • following instruction/guides, was how I knew that CUDA 8RC is suited to OSX 10.11.5 (due to the Xcode/Driver issue)
    • following instruction/guides, was how I knew separate CUDA 7.5 and CUDA 8RC modifications to make to my .bash_profile
  • I am okay with cudadriver being updated (I actually like it - since toolkit based driver is not available for general download yet).
    • I once noticed CUDA 8RC installing another GPU driver different to the 346.xx versions (this was however not consistent)
    • dilemma is that CUDA 8RC “still” complains that “update is required” to the same 8.x driver that it itself installed
    • dilemma is I have no idea where to get newer drivers other than 346.xx (not on nvidia), do you have suggestion of where ?
    • evidence does not show that CUDA 8RC can work with the stock OSX GPU driver

Summary (beyond my control):

  • CUDA 8RC previously worked for my rMBP (A1398) with OSX 10.11.5 (and Xcode 7.3) BUT no longer works due to GPU driver
  • need download source for Nvidia drivers (that are not 346.xx) that are known to work for OSX 10.11.5 (on model A1398)
  • need download source for Cuda driver (newer than 8.x) that would make it stop saying “update is required”

Would appreciate further suggestions

One more clarification:

  • from link 1 it is implied that BOTH GPU driver and Cuda driver are installed by the toolkit (which tallies with my experience with CUDA 8RC)
  • yet link 2 says cuda driver is installed but no mention of GPU driver
  • I have checked but cannot find the OSX 10.11.5 equivalent of version “368.39 driver”
  • lets assume I “uncheck” cudadriver option while installing “cuda toolkit” so as to avoid overwriting the OSX GPU driver
  • yet which “Cuda driver” would the toolkit use, since there is no standalone “8.x” cuda driver download yet for OS X 10.11.5
  • link 3 shows that cuda driver 7.5.29 is still the highest publicly available cuda driver for now and not “8.x”

UPDATE (with default OSX Driver (GeForce 10.10.10 310.42.25f01) installed [see /System/Library/Extensions/GeForce.Kext])

- 7.5.29 (cuda driver) installed
- restart
- observed “GPU Driver Version: No version found” + “not seeing GT650M GPU” + “CUDA Driver Version: 7.5.29” + unstable
- installed el-capitan update 
- observed “GPU Driver Version: No version found” + “seeing GT 650M GPU” + “CUDA Driver Version: 7.5.29” + stable
- restarted
- observed “GPU Driver Version: No version found” + “not seeing GT650M GPU” + “CUDA Driver Version: 7.5.29” + stable
- installed CUDA 8RC (cuda_8.0.29_mac)
- observed “GPU Driver Version: No version found” + “not longer seeing GT650M GPU” + “CUDA Driver Version: 7.5.29” + stable
- basically NO success

SUMMARY:
- new GPU driver is required to make OSX 10.11.5 work with CUDA
- new Cuda driver is required to make OSX 10.11.5 work with CUDA
- CUDA 8.x is the only option going forward