MAC CUDA driver fully compatible with macOS High Sierra 10.13 (error

Hi guys,

The macOS High Sierra 10.13 upgraded make me sick because of its incompatible with the GPU CUDA driver. I came here after weeks searching for a solution that fixes the annoying “Update Required” message showing everytime my Mac startups, also making all of my CUDA-required software I using like Adobe Premiere/After Effect runs and renders very slow. Finally, I must come here and register an account for only this, and glad I found it, the solution that saves my life XD

Ok so I won’t take your time anymore on how happy I did, let’s go straight to the point how I really made it:
The only information you need to know is: Right now the macOS’ native graphics driver that help the system communicate with the nVIDIA GPU, is still not updated to the really compatible version. So what we have to do here is to install the “web version” of the driver, which is an OFFICIAL version from nVIDIA, it’s just not a “native version” from Apple.

In quick view, what I have done to solve the problem:
1. Uninstall the incompatible “native version” CUDA from my Mac.
2. Download and install the latest “web version” of NVIDIA DRIVER and CUDA from nVIDIA’s website.

Let’s go in a more detailed how to fix this tutorial:
STEP 1. UNINSTALL THE MACOS CUDA DRIVER
Navigate and delete all CUDA existing native drivers and related components installed on your Mac (by right-clicking at Finder on the dock and selecting “Go to folder…”:

  • /System/Library/Extensions/CUDA.kext
  • /Library/Frameworks/CUDA.framework
  • /Library/LaunchAgents/com.nvidia.CUDASoftwareUpdate.plist
  • /Library/PreferencePanes/CUDA/Preferences.prefPane
  • /System/Library/StartupItems/CUDA/
  • /Developer/NVIDIA/CUDA-5.0
  • /usr/local/cuda
    (Some of those will be empty and it’s normal)

OR you can try the method that use Terminal to do that from here: http://docs.nvidia.com/cuda/cuda-installation-guide-mac-os-x/index.html#uninstall

After step 1, make sure to do a restart to really get your Mac to a fresh state.

STEP 2. DOWNLOAD AND INSTALL THE NVIDIA DRIVER

These installations may require you to restart your computer several times, just go ahead. And do it one more time when everything are all installed, too!

…aaaaand boooom, it’s done!
I think you may not see the annoying “Update Required” message anymore, also there’s now an nVIDIA icon on your menu bar - which showing the new nVIDIA web version driver is managing the GPU right now (Thank God!). You can also hide it in System Preferences > NVIDIA Driver Manager and uncheck the “Show NVIDIA Driver Manager in menu bar” checkbox. Try checking your CUDA-required software to make sure you have solved the problem, too.

If this could help you, please leave a reply so other people can see!
That’s all. I hope it helps! Sorry for my bad English :P

Thanks, and have a good day from now!!
Hoa Nguyen.

After several attempts i managed to download the web driver and cuda driver.
Did what you said, and everything is working fine now.
Thank you very much for sharing!

solution is not good

Thanks a lot for figuring this out.

However, there does not seem to be a current driver from NVIDIA for the GTX 780M in my 27" iMac (late 2013), so it seems I’m stuck with an unusable CUDA driver in 10.13 (and 10.13.1).

The graphics driver to which you linked explicitly lists the supported graphics chipsets, and the 700M series is missing.

EDIT: it seems the graphics webdriver works with the GTX 780M, even though support for the iMac 14,2 is listed as “beta”.

Bernd

Hello, I also got this new solution work, iMac 27’ Late 2013. Thank you.

https://plus.google.com/u/0/photos/photo/115397020389997734277/6485234380930586514?icm=false&iso=true&authkey=CIb04tDWwfWgPg

Yes, IT WORKS!

If you get the update message after you installed both packages, just restart your computer once more and everything should be fine.

Thank you! @hkunkun

The amount of frustration you’ve saved so many people by finding this solution cannot be measured. Thank you. I was ready to throw out this mac, CC2018, my drives, whatever.

I’d rolled back to a 8 series driver, and while better it was still unstable. Not anymore. Everything is rock solid.

Now it’s time to wonder why Apple and Adobe missed this. But before that, let me say thank you again.

P

Yes! Thank you so much!! This worked on my Late 2013 27" iMac with GTX 780M. Just make sure you restart your computer one last time after everything is installed!

Thanks again for your help! It’s a shame Apple and Adobe left us hanging like this.

Thank you so much for posting this. It worked perfectly on my Mid-2014 15" MacBook Pro Retina with the GT750M GPU. I was annoyed by the update message every boot, and disappointed that I could no longer access the real power of my GPU. Your post has solved all of this. Thanks again!

Hi all,

I followed hkunkun’s instructions and now I run into a new error when I run my CUDA software. I get '(error code no CUDA-capable device is detected)! ’ Also I go to the Energy Saver settings in the control panel and I switch off automatic graphic switching and then my screen goes black except you can still see and move the mouse. Anyone else get this error? My graphics card is a GeForce GT 650M and I am on MACOSX 10.13.1. THANK YOU!

EDIT: So it work when I run in Sudo but the window goes black during execution how do I avoid this.

Hi all,

I followed hkunkun’s instructions and now I run into a new error when I run my CUDA software. I get '(error code no CUDA-capable device is detected)! ’ Also I go to the Energy Saver settings in the control panel and I switch off automatic graphic switching and then my screen goes black except you can still see and move the mouse. Anyone else get this error? My graphics card is a GeForce GT 650M and I am on MACOSX 10.13.1. THANK YOU!

Hoa: Your fix has worked for me. FCPX running smoothly again. I have a late 2013 27 in. iMac with High Sierra OS 10.13.1 and a GTX 780M installed. I still get the “need update” message when I click the CUDA icon in Settings. However, I also have a new icon for NVIDIA Driver Manager, which shows that I am using the Nvidia web driver.

Thanks very much. Jim.

Hi,

I have following config for my mac but i am not able to install properly cuda toolkit as well as cuda drivers.

MacBook Pro (15-inch, Mid 2012)
OSX version - 10.13.1 (17B48)
NVIDIA - NVIDIA GeForce GT 650M 512 MB

I tried for both cuda 8 as well as cuda 9 but were in vain. I downloaded drivers from the specified urls mention here.

Also tried with Xcode (7.3; 8.3 and 9.0).

After upgradation everything went for a toss. Now, nothing is working for me.

My mac is going to support cuda drivers or not ?

Thanks in advance

So, for this work properly, after a clean uninstall and install Quadro & GeForce MacOS Driver Release we should not install the latest driver CUDA 9.0.222 driver for Mac and instead install the older CUDA 9.0.214 driver for Mac. Is that correct?

I’m on a MacBook Pro (Retina, 15-inch, Late 2013) with a NVIDIA GeForce GT 750M 2 GB using macOS High Sierra 10.13.1 (17B48). The http://www.nvidia.com/download/driverResults.aspx/126157/en-us says my GPU is not supported by this Quadro & GeForce MacOS Driver Release, so I’m apprehensive.

Thank you very much.

Daniborgs: Sounds like you and I have the same machine and same issue.

I investigated the manual uninstall steps outlined by hkunkun and found I was missing about 3 of the directories that are outlined; nothing there to delete. My machine IS working. I get the error on startup but that’s it. The MBP does seem to work harder to open Photoshop files and so on but again, it’s working…I don’t want to nuke it outright with a long-hand fix.

Lemme know what happens should you pull the trigger.

Cheers

@fergwe: My machine is also running, apparently normally. I let you know what happens when I pull the trigger.

My concern is that I can not select CUDA Driver in Adobe Photoshop and Media Enconder and I’m afraid the Mac is not running to its full potential. It seems slower when it encodes videos. I don’t mind the upgrade notice.

These folders/files mentioned in this tutorial do not exist in my system

/System/Library/Extensions/CUDA.kext
/Developer/NVIDIA/CUDA-5.0
/System/Library/StartupItems/CUDA/

These folders/files do exist

/Library/Frameworks/CUDA.framework
/Library/LaunchAgents/com.nvidia.CUDASoftwareUpdate.plist
/Library/PreferencePanes/CUDA/Preferences.prefPane
/usr/local/cuda

@hkunkun: Is this tutorial completely accurate? By the way, thanks for share your solution.

Respect hkunkun, indeed, for taking time and posting such a totally awesome bunch of info with details. It did, solved the cuda driver’s issue.

Bonjour,

J’ai un MacBook Pro (rétina 15’ mi-2015) version 10.13.1 avec deux cartes graphiques : une Intel Iris Pro Graphics et une AMD Radeon R9 M370X.

Depuis que j’ai effectué la MÀJ de El Capitan vers High Sierra, l’accélérateur de carte graphique CUDA de Nvidia n’est plus détecté alors que la MÀJ de Cuda Driver version 9.0.222 s’est faite sans problème.

Est-ce que je dois utiliser votre procédure, bien que le message ne soit pas update requiered, mais No GPU Detected ? Et que GPU Driver version : No version found apparait en grisé (juste en dessous)

Il me semble qu’avant ça fonctionnait avnt la MÀj vers High Sierra mais j’ai un doute : mes cartes graphiques sont-elles bien compatibles avec CUDA ?

Après de longues et infructueuses recherches sur le web, vous êtes le seul qui semble pouvoir m’aider…

Merci pour votre réponse.

Je suspecte que CUDA n’a jamais fonctionné sur ton MacBook Pro. Une carte de NVIDIA doît être nécéssaire pour utiliser CUDA. À moin que tu aies une carte graphique externe de NVIDIA, e.g. branchée par Thunderbolt, il ne me surprenerais pas qu’Apple a décidé de simplement ne pas installer les pilotes reliés à NVIDIA durant la MÀJ vers High Sierra, puisqu’ils sont inutiles pour toi.

Merci pour ta réponse. N’ayant jamais eu de carte graphique externe, je ne comprend pas pourquoi Adobe (pas joignable ni au tel, ni par tchat !) m’a fait l’installer et pourquoi le cuda me demandais de faire ses mises à jour (que j’ai faites), jusqu’à la dernière que je n’ai pas pu faire car ça me disait de faire avant celle de Sierra ? Penses-tu qu’Adobe le fasse installer à tout le monde, même si ce n’est pas utile ? Et j’ai lu quelque part que pour utiliser Cuda, il fallait avoir Intel… Est-ce que ça t’inspire quelque choses ?