MAC CUDA driver fully compatible with macOS High Sierra 10.13 (error

I too had the same problem as daniborgs with not being able to find the provided folders. Also have the same laptop. Therefore, i wasn’t able to select CUDA in any of my Adobe programs.

After multiple attempts, I used CleanMyMac’s extension remover to remove all traces of CUDA and nVidia software. I then installed both the web driver and CUDA software. Checked the CUDA manager and it seems to be working! Did a few restarts and checked all Adobe software, and CUDA was available.

If you can’t manually find/remove the selected folders, I would try the CleanMyMac route and see if that helps.

Hello again.

I installed high sierra on top of sierra and this trick worked for me.
The problem is that last night I did a clean install of high sierra and now I get a black screen if I install the cuda driver.
Every time I launch an app that requires graphics switching (from intel to nvidia) I get the black screen.
I’m using the osx default graphics driver now and it works fine, but I guess the gpu is not working at its full potential.

Any thoughts on this?
Thanks in advance.

I tried this and updated both drivers on my macbook pro with geforce 750m (mid 2014).
Two problems:

  • In System Report > Extensions I see both the Geforce and Geforce Web items, but the normal Geforce is the one that is active. How do I make the Web one active?
  • In Adobe Premiere I have no Cuda option.
  • In Davinci Resolve, if I select Cuda and restart the program it tells me it can’t find a cuda capable device.

What gives? In the Nvidia Driver Manager I have the Web driver activated.
Hope someone can help further.

Works properly now. I did almost exactly what @hkunkun says. Only the files and folders below were removed from my system, the others mentioned did not exist.

/Library/Frameworks/CUDA.framework
/Library/LaunchAgents/com.nvidia.CUDASoftwareUpdate.plist
/Library/PreferencePanes/CUDA/Preferences.prefPane
/usr/local/cuda

First I uninstall the CUDA drivers that was installed. Restart. Then install QUADRO & GEFORCE MACOS DRIVER RELEASE 378.10.10.10.20.107 (web drivers for macOS High Sierra 10.13.1). Restart. Finally install CUDA 9.0.222 driver for Mac. Restart.

I’m on a MacBook Pro (Retina, 15-inch, Late 2013) with a NVIDIA GeForce GT 750M 2 GB using macOS High Sierra 10.13.1 (17B48) and now I’m able to select CUDA drivers in Adobe Media Encoder and Premiere.

Thank you very much all you guys for the kind support.

Hi there,

Thaaaanks a lot for saving us ^^
I spent over a month with apple and Nvidia support to figure this out, Apple said “you should ask to Nvidia, they had a beta version to update their driver”… Ok thanks Apple, don’t forget that the Nvidia card is shipped with my macbook pro… After contacting Nvidia’s support center, the answer given was “Someone seems to figure this out” and gave me the link to your solution…

So a big thank you.

Loïc

I tried all the steps exactly as this, but still my web driver does not let me use cuda on the drive manager , I go to NVIDIA Driver Manager and select “Use Nvidia Graphics Driver downloaded from Nvidia’s web site” and it asks me to restart the computer for it make the change (all of this after I went through the process step by step) and when the computer reboots it goes back to the OSX Default graphics driver. Please help!!

@hkunkun Thank you!

This worked like a charm—until today.

Unfortunately, Apple released another security update for macOS 10.13.1 https://support.apple.com/en-us/HT208315 which is causing the “Update Required” error again.

Question: How did you find the updated macOS driver release? I can’t find any Mac search options on http://www.nvidia.com/Download/index.aspx

Would love a way to know when the next update is released.

Thanks again.

I have exactly the same situation! The new security update for macOS 10.13.1 messed things up again on my Late 2013 Retina Macbook Pro. The CUDA driver update required message is showing again, and the nvidia web driver is not compatible with current system and you are forced to use default os x driver, sigh. I also cannot find out the proper list on nvidia.com for the newest driver for Quadro & GeForce MacOS Driver Release, which is kinda frustrating. I guess we have to rely on the build-in Update function.

I was about to install this macOS update, than I decided to set a password to the Root user, and suddenly the warning to install this macOS update on the AppStore is gone. I think it wasn’t necessary to install it. I continue with the CUDA Driver in the latest version and without that infamous warning.

@kevedosdesert I’ve removed the files / folders, using rm and sudo commands this way:

sudo rm -r /Library/Frameworks/CUDA.framework
sudo rm -r /Library/LaunchAgents/com.nvidia.CUDASoftwareUpdate.plist
sudo rm -r /Library/PreferencePanes/CUDA/Preferences.prefPane
sudo rm -r /usr/local/cuda

I did not select OS X Default Graphics Driver from NVIDIA Web Driver Manager in any moment.

Hope it helps.

Few problems here:

  1. Mac OS refuses to allow CUDA. kext to be removed because “Mac OS requires it.” Using terminal commands doesn’t work either.
  2. I removed other files and restarted. Then tried installing the web driver. It just says “Mac OS X version is incompatible” and refuses to let it be installed. Trying to install the update to Cuda fails as well.

I am on the most current version of the OS and the most current Macbook Pro. What can I do to fix this?

Here is some updates for those who might have the same problem:

  • nvidia has released an update version for the web driver and it is now working properly again.
  • Just use the build in ‘Update’ feature in NVidia Driver Manager. The new version is 378.10.10.10.20.109.

The web driver has finally been installed, but I cannot install the new update now. I’ve still been unable to delete the Cuda.kext. When I try to install the update it still says “installation failed.” As far as I can tell, the Cuda is still not working even tho my web driver says its using nvidia web driver.

I installed The new version is 378.10.10.10.20.109. Still I cannot use the Nvidia web driver. It does let me select the driver and tells me that I need to restart for the change to take place but once it reboots it goes back to the OSX default graphic driver. This is frustrating.

Hi all

This had worked for me until yesterday’s Mac update, when my Web Driver stopped working and again found I couldn’t update from the CUDA module in System Preferences. I had tried deleting everything and reinstalling the Web Driver, but kept being told it wasn’t compatible.

I’ve tried it today and it’s now working. I suspect my issue was that I hadn’t completely deleted all the files (Nvidia seem to make things quite difficult, including some needless questions for registering for this forum.)

I followed the directions in the OP, and like many here could not find the following:

  • /System/Library/Extensions/CUDA.kext
  • /System/Library/StartupItems/CUDA/
  • /Developer/NVIDIA/CUDA-5.0
  • /usr/local/cuda

However, within the folders I could access there seemed to be shortcuts to other folders, so this time I went into those folders individually and deleted all the files within, as I suspect I was only deleting the shortcut links before.

After a restart I then downloaded the WebDriver-378.10.10.10.20.109.pkg from here: https://images.nvidia.com/mac/pkg/378/WebDriver-378.10.10.10.20.109.pkg and it installed without issue.

After a restart I then downloaded the CUDA Support Driver linked in the OP (http://www.nvidia.com/object/macosx-cuda-9.0.222-driver.html) which again installed without any issues this time.

I’ve restarted and everything seems to be working OK and the fans on my Mac are no longer deafening :-)

I just wanted to register to thank hkunkun and the other posters for their help and let other people who are as technically inept as me how I managed to get it working.

Which folders and files did you delete to do this?

bogdan.pop.r

I have the same problem. I have a GeForce GT 650M. Most people I noticed that got it working have 750Ms. Also I just noticed that under system info>disabled software, NVIDIA Cuda is disabled. I have a picture attached. Maybe this is the problem and it needs to be enabled somehow. On someone’s who has it working, is this true for yours?

Current problem for me is that I was able to delete all the files needed (including the .kext), installed web driver, then the most recent Cuda update. Once I restart, all the cuda files are back in their place and the update rquireed message pops up again. All programs still don’t work with Cuda, so it hasn’t helped. I did install the web driver first if that makes any difference.

Any ideas? Please help

Apple’s recent High Sierra Security Update disabled NVIDIA’s web driver and reset to the OS X Default Graphics Driver.
But only two days later, NVIDIA’s Driver Manager (which has been installed during the procedure that is subject of this thread) notified me about a driver update: version 378.10.10.10.20.109 was ready for installation. I installed it, rebooted and everything is working fine again. My CUDA Driver version is now 9.0.222.

I think, it’s important to have the NVIDIA Driver Manager installed: this tool notifies about driver updates, downloads the related file and starts the driver installation after consent.

(MacBookPro 15" Late 2013, NVIDIA GeForce GT 750M)

The solution above seemed to work for me (MacBook Pro; late 2013 with 750)

It cleared the start-up nag (finally) and installed the Driver Manager without a hitch; and updated all the drivers with a reboot.

I had the missing files/directory issue too but never chased that down–just installed the package linked above.

God’s Speed.