使用spi3 連接 flash

I want to use spi3 to connect to flash

I add this setting
Doesn’t seem to appear spidev
spi@3230000 {
status = “okay”;
spi@0 {
compatible = “tegra-spidev”;
reg = <0x0>;
spi-max-frequency = <33000000>;
controller-data {
nvidia,enable-hw-based-cs;
nvidia,rx-clk-tap-delay = <0x11>;
};
};

How to enable spidev??
I want to be able to access spi flash
Which command should I use?

Should flash using qspi interface?
You need enable spidev by modprobe devspi

I want use spi@3230000
insmod spidev.ko

I can see
/dev/spidev0.1

/sys/devices/3210000.spi
/sys/devices/c260000.spi

can’t see about spi@3230000

spi@3230000 is spi2.x you need enable it by add spidev under spi@3230000

		spi@0 {
			compatible = "spidev";
			reg = <0x0>;
			spi-max-frequency = <0x2faf080>;

			controller-data {
				nvidia,enable-hw-based-cs;
				nvidia,rx-clk-tap-delay = <0x10>;
				nvidia,tx-clk-tap-delay = <0x0>;
			};
		};

I can see /dev/spidev2.0 …
wait to connect MISO and MOSI …to test spidev_test

root@user-desktop:/home/user# ./spidev_test -D /dev/spidev2.0 -v
spi mode: 0x0
bits per word: 8
max speed: 500000 Hz (500 KHz)
TX | FF FF FF FF FF FF 40 00 00 00 00 95 FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF F0 0D | …@…?
RX | 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 | …

Have a reference to below link to check the cfg file, you may need modify the spi3_xxx for spi2 function.

Can’t use SPI3?

pinmux.0x0243d008 = 0x00000001; # spi3_miso_py1: rsvd1, tristate-disable, input-disable, io_high_voltage-disable, lpdr-disable
pinmux.0x0243d060 = 0x00000411; # spi3_mosi_py2: rsvd1, tristate-enable, input-disable, io_high_voltage-disable, lpdr-disable
pinmux.0x0243d028 = 0x00000001; # spi3_cs1_py4: rsvd1, tristate-disable, input-disable, io_high_voltage-disable, lpdr-disable
pinmux.0x0243d048 = 0x00000415; # spi3_sck_py0: rsvd1, pull-down, tristate-enable, input-disable, io_high_voltage-disable, lpdr-disable
pinmux.0x0243d018 = 0x00000415; # spi3_cs0_py3: rsvd1, pull-down, tristate-enable, input-disable, io_high_voltage-disable, lpdr-disabl

Try to modify it by devmem2 like the reference topic to confirm it.