stutter on geforce 1080ti when upgrading from RHEL 7.1 to RHEL 7.5 and running MATE

I have a box with a 710 gt, 980 ti, and 1080 ti running redhat linux and an OSG application.
when I run under RHEL 7.1 the application runs perfectly on both the 980 and 1080.
when i run under RHEL 7.5 the application runs fine on the 980 but stutters on the 1080.
the only difference is the OS version as it on the same box just swapping boot drives.
the application and all .so files are contained on a separate drive.

updated that this only occurs when running MATE
nvidia-bug-report.log.gz (1.38 MB)

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

uploaded bug report. also verified that a 1060 card behaves the same as 1080.

Ok, everything seems to be set up fine, no errors. Can you please check for a driver bug by installing a v390 driver, in case you’re using cuda 10 use a v384 driver.
https://http.download.nvidia.com/XFree86/Linux-x86_64/

i have tried 390 410 and 415
i will make a clone and try upgrading to 7.6 since it is available now

upgraded kernel and all software pkgs on the system and the problem still exists
driver version 390 no longer works. system hangs when X starts

i have seen where nvidia-settings is only reporting the PCIe width as x8 for the 1080 and x16 for the 980. is this normal?

never mind. swapped slots with same results.

Updated : the problem only occurs when running the MATE desktop. If running gnome it runs fine on both cards. For this particular application I can live with running gnome but would like to understand why MATE and 7.5 with a 1080ti card has issues. must be a combination of all three items. if any one of the other items is different it will run fine.