Sudo ./apply_binaries.sh report error!

I met a issue when running sudo ./apply_binaries.sh in latest JetPack_4.4_DP_Linux_DP_JETSON_XAVIER_NX

This command report error as below:
~/nvidia_NX_440_DP/nvidia_sdk/JetPack_4.4_DP_Linux_DP_JETSON_XAVIER_NX/Linux_for_Tegra$ sudo ./apply_binaries.sh
Using rootfs directory of: /home/yy/nvidia_NX_440_DP/nvidia_sdk/JetPack_4.4_DP_Linux_DP_JETSON_XAVIER_NX/Linux_for_Tegra/rootfs
/home/yy/nvidia_NX_440_DP/nvidia_sdk/JetPack_4.4_DP_Linux_DP_JETSON_XAVIER_NX/Linux_for_Tegra/nv_tegra/nv-apply-debs.sh
Root file system directory is /home/yy/nvidia_NX_440_DP/nvidia_sdk/JetPack_4.4_DP_Linux_DP_JETSON_XAVIER_NX/Linux_for_Tegra/rootfs
Copying public debian packages to rootfs
Start L4T BSP package installation
QEMU binary is not available, looking for QEMU from host system
Found /usr/bin/qemu-aarch64-static
Installing QEMU binary in rootfs
~/nvidia_NX_440_DP/nvidia_sdk/JetPack_4.4_DP_Linux_DP_JETSON_XAVIER_NX/Linux_for_Tegra/rootfs ~/nvidia_NX_440_DP/nvidia_sdk/JetPack_4.4_DP_Linux_DP_JETSON_XAVIER_NX/Linux_for_Tegra
Installing BSP Debian packages in /home/yy/nvidia_NX_440_DP/nvidia_sdk/JetPack_4.4_DP_Linux_DP_JETSON_XAVIER_NX/Linux_for_Tegra/rootfs
(Reading database … 123395 files and directories currently installed.)
Preparing to unpack …/nvidia-l4t-core_32.4.2-20200408182620_arm64.deb …
Pre-installing… skip compatibility checking.
Unpacking nvidia-l4t-core (32.4.2-20200408182620) over (32.4.2-20200408182620) …
Setting up nvidia-l4t-core (32.4.2-20200408182620) …
(Reading database … 123395 files and directories currently installed.)
Preparing to unpack …/jetson-gpio-common_2.0.8_arm64.deb …
Unpacking jetson-gpio-common (2.0.8) over (2.0.8) …
Preparing to unpack …/python3-jetson-gpio_2.0.8_arm64.deb …
qemu: Unsupported syscall: 278
Fatal Python error: failed to get random numbers to initialize Python

qemu: uncaught target signal 6 (Aborted) - core dumped
Aborted (core dumped)
dpkg: warning: old python3-jetson-gpio package pre-removal script subprocess returned error exit status 134
dpkg: trying script from the new package instead …
qemu: Unsupported syscall: 278
Fatal Python error: failed to get random numbers to initialize Python

qemu: uncaught target signal 6 (Aborted) - core dumped
Aborted (core dumped)
dpkg: error processing archive /opt/nvidia/l4t-packages/standalone/python3-jetson-gpio_2.0.8_arm64.deb (–install):
new python3-jetson-gpio package pre-removal script subprocess returned error exit status 134
Preparing to unpack …/python-jetson-gpio_2.0.8_arm64.deb …
Unpacking python-jetson-gpio (2.0.8) over (2.0.8) …
Preparing to unpack …/nvidia-l4t-3d-core_32.4.2-20200408182620_arm64.deb …
Unpacking nvidia-l4t-3d-core (32.4.2-20200408182620) over (32.4.2-20200408182620) …
Preparing to unpack …/nvidia-l4t-apt-source_32.4.2-20200408182620_arm64.deb …
Unpacking nvidia-l4t-apt-source (32.4.2-20200408182620) over (32.4.2-20200408182620) …
Preparing to unpack …/nvidia-l4t-camera_32.4.2-20200408182620_arm64.deb …
Unpacking nvidia-l4t-camera (32.4.2-20200408182620) over (32.4.2-20200408182620) …
Preparing to unpack …/nvidia-l4t-configs_32.4.2-20200408182620_arm64.deb …
Unpacking nvidia-l4t-configs (32.4.2-20200408182620) over (32.4.2-20200408182620) …
Preparing to unpack …/nvidia-l4t-cuda_32.4.2-20200408182620_arm64.deb …
Unpacking nvidia-l4t-cuda (32.4.2-20200408182620) over (32.4.2-20200408182620) …
Preparing to unpack …/nvidia-l4t-firmware_32.4.2-20200408182620_arm64.deb …
Unpacking nvidia-l4t-firmware (32.4.2-20200408182620) over (32.4.2-20200408182620) …
Preparing to unpack …/nvidia-l4t-graphics-demos_32.4.2-20200408182620_arm64.deb …
Unpacking nvidia-l4t-graphics-demos (32.4.2-20200408182620) over (32.4.2-20200408182620) …
Preparing to unpack …/nvidia-l4t-gstreamer_32.4.2-20200408182620_arm64.deb …
Unpacking nvidia-l4t-gstreamer (32.4.2-20200408182620) over (32.4.2-20200408182620) …
Preparing to unpack …/nvidia-l4t-init_32.4.2-20200408182620_arm64.deb …
Unpacking nvidia-l4t-init (32.4.2-20200408182620) over (32.4.2-20200408182620) …
Preparing to unpack …/nvidia-l4t-initrd_32.4.2-20200408182620_arm64.deb …
Unpacking nvidia-l4t-initrd (32.4.2-20200408182620) over (32.4.2-20200408182620) …
Preparing to unpack …/nvidia-l4t-jetson-io_32.4.2-20200408182620_arm64.deb …
Unpacking nvidia-l4t-jetson-io (32.4.2-20200408182620) over (32.4.2-20200408182620) …
Preparing to unpack …/nvidia-l4t-multimedia_32.4.2-20200408182620_arm64.deb …
Unpacking nvidia-l4t-multimedia (32.4.2-20200408182620) over (32.4.2-20200408182620) …
Preparing to unpack …/nvidia-l4t-multimedia-utils_32.4.2-20200408182620_arm64.deb …
Unpacking nvidia-l4t-multimedia-utils (32.4.2-20200408182620) over (32.4.2-20200408182620) …
Preparing to unpack …/nvidia-l4t-oem-config_32.4.2-20200408182620_arm64.deb …
Unpacking nvidia-l4t-oem-config (32.4.2-20200408182620) over (32.4.2-20200408182620) …
Preparing to unpack …/nvidia-l4t-tools_32.4.2-20200408182620_arm64.deb …
Unpacking nvidia-l4t-tools (32.4.2-20200408182620) over (32.4.2-20200408182620) …
Preparing to unpack …/nvidia-l4t-wayland_32.4.2-20200408182620_arm64.deb …
Unpacking nvidia-l4t-wayland (32.4.2-20200408182620) over (32.4.2-20200408182620) …
Preparing to unpack …/nvidia-l4t-weston_32.4.2-20200408182620_arm64.deb …
Unpacking nvidia-l4t-weston (32.4.2-20200408182620) over (32.4.2-20200408182620) …
Preparing to unpack …/nvidia-l4t-x11_32.4.2-20200408182620_arm64.deb …
Unpacking nvidia-l4t-x11 (32.4.2-20200408182620) over (32.4.2-20200408182620) …
Preparing to unpack …/nvidia-l4t-xusb-firmware_32.4.2-20200408182620_arm64.deb …
Unpacking nvidia-l4t-xusb-firmware (32.4.2-20200408182620) over (32.4.2-20200408182620) …
Preparing to unpack …/nvidia-l4t-kernel_4.9.140-tegra-32.4.2-20200408182620_arm64.deb …
Unpacking nvidia-l4t-kernel (4.9.140-tegra-32.4.2-20200408182620) over (4.9.140-tegra-32.4.2-20200408182620) …
Preparing to unpack …/nvidia-l4t-kernel-dtbs_4.9.140-tegra-32.4.2-20200408182620_arm64.deb …
Unpacking nvidia-l4t-kernel-dtbs (4.9.140-tegra-32.4.2-20200408182620) over (4.9.140-tegra-32.4.2-20200408182620) …
Preparing to unpack …/nvidia-l4t-kernel-headers_4.9.140-tegra-32.4.2-20200408182620_arm64.deb …
Unpacking nvidia-l4t-kernel-headers (4.9.140-tegra-32.4.2-20200408182620) over (4.9.140-tegra-32.4.2-20200408182620) …
Preparing to unpack …/nvidia-l4t-bootloader_32.4.2-20200408182620_arm64.deb …
Pre-installing bootloader package, skip flashing
Unpacking nvidia-l4t-bootloader (32.4.2-20200408182620) over (32.4.2-20200408182620) …
Setting up jetson-gpio-common (2.0.8) …
Setting up python-jetson-gpio (2.0.8) …
Setting up nvidia-l4t-apt-source (32.4.2-20200408182620) …
Pre-installing… skip changing source list.
Setting up nvidia-l4t-configs (32.4.2-20200408182620) …
Setting up nvidia-l4t-firmware (32.4.2-20200408182620) …
Setting up nvidia-l4t-init (32.4.2-20200408182620) …
groupadd: group ‘crypto’ already exists
groupadd: group ‘trusty’ already exists
dpkg: error processing package nvidia-l4t-init (–install):
installed nvidia-l4t-init package post-installation script subprocess returned error exit status 9
Setting up nvidia-l4t-multimedia-utils (32.4.2-20200408182620) …
Setting up nvidia-l4t-oem-config (32.4.2-20200408182620) …
Setting up nvidia-l4t-tools (32.4.2-20200408182620) …
Setting up nvidia-l4t-wayland (32.4.2-20200408182620) …
Setting up nvidia-l4t-weston (32.4.2-20200408182620) …
dpkg: dependency problems prevent configuration of nvidia-l4t-x11:
nvidia-l4t-x11 depends on nvidia-l4t-init (= 32.4.2-20200408182620); however:
Package nvidia-l4t-init is not configured yet.

dpkg: error processing package nvidia-l4t-x11 (–install):
dependency problems - leaving unconfigured
Setting up nvidia-l4t-xusb-firmware (32.4.2-20200408182620) …
Pre-installing xusb firmware package, skip flashing
Setting up nvidia-l4t-kernel (4.9.140-tegra-32.4.2-20200408182620) …
Setting up nvidia-l4t-kernel-dtbs (4.9.140-tegra-32.4.2-20200408182620) …
Setting up nvidia-l4t-kernel-headers (4.9.140-tegra-32.4.2-20200408182620) …
Unpacking kernel headers…
Setting up nvidia-l4t-bootloader (32.4.2-20200408182620) …
Pre-installing bootloader package, skip flashing
dpkg: dependency problems prevent configuration of nvidia-l4t-3d-core:
nvidia-l4t-3d-core depends on nvidia-l4t-init (= 32.4.2-20200408182620); however:
Package nvidia-l4t-init is not configured yet.
nvidia-l4t-3d-core depends on nvidia-l4t-x11 (= 32.4.2-20200408182620); however:
Package nvidia-l4t-x11 is not configured yet.

dpkg: error processing package nvidia-l4t-3d-core (–install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nvidia-l4t-camera:
nvidia-l4t-camera depends on nvidia-l4t-3d-core (= 32.4.2-20200408182620); however:
Package nvidia-l4t-3d-core is not configured yet.

dpkg: error processing package nvidia-l4t-camera (–install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nvidia-l4t-cuda:
nvidia-l4t-cuda depends on nvidia-l4t-3d-core (= 32.4.2-20200408182620); however:
Package nvidia-l4t-3d-core is not configured yet.

dpkg: error processing package nvidia-l4t-cuda (–install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nvidia-l4t-graphics-demos:
nvidia-l4t-graphics-demos depends on nvidia-l4t-3d-core (= 32.4.2-20200408182620); however:
Package nvidia-l4t-3d-core is not configured yet.

dpkg: error processing package nvidia-l4t-graphics-demos (–install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nvidia-l4t-gstreamer:
nvidia-l4t-gstreamer depends on nvidia-l4t-camera (= 32.4.2-20200408182620); however:
Package nvidia-l4t-camera is not configured yet.
nvidia-l4t-gstreamer depends on nvidia-l4t-cuda (= 32.4.2-20200408182620); however:
Package nvidia-l4t-cuda is not configured yet.

dpkg: error processing package nvidia-l4t-gstreamer (–install):
dependency problems - leaving unconfigured
Setting up nvidia-l4t-initrd (32.4.2-20200408182620) …
Setting up nvidia-l4t-jetson-io (32.4.2-20200408182620) …
dpkg: dependency problems prevent configuration of nvidia-l4t-multimedia:
nvidia-l4t-multimedia depends on nvidia-l4t-3d-core (= 32.4.2-20200408182620); however:
Package nvidia-l4t-3d-core is not configured yet.
nvidia-l4t-multimedia depends on nvidia-l4t-cuda (= 32.4.2-20200408182620); however:
Package nvidia-l4t-cuda is not configured yet.

dpkg: error processing package nvidia-l4t-multimedia (–install):
dependency problems - leaving unconfigured
Processing triggers for nvidia-l4t-kernel (4.9.140-tegra-32.4.2-20200408182620) …
Errors were encountered while processing:
/opt/nvidia/l4t-packages/standalone/python3-jetson-gpio_2.0.8_arm64.deb
nvidia-l4t-init
nvidia-l4t-x11
nvidia-l4t-3d-core
nvidia-l4t-camera
nvidia-l4t-cuda
nvidia-l4t-graphics-demos
nvidia-l4t-gstreamer
nvidia-l4t-multimedia

These errors will cause system package configuration fail when ubuntu first boot up.

In JetPack 4.4 EA. This command works fine.

Please help if you know the reason.

1 Like

If you don’t already have package “qemu-user-static” installed, could you try adding this ("sudo apt-get install qemu-user-static")? After this is done, regardless of whether you had this package or not, then run command “sudo dpkg-reconfigure qemu-user-static”. Then try apply_binaries.sh again.

Same condition, the result is still error

Setting up nvidia-l4t-init (32.4.2-20200408182620) …
groupadd: group ‘crypto’ already exists
groupadd: group ‘trusty’ already exists
dpkg: error processing package nvidia-l4t-init (–install):
installed nvidia-l4t-init package post-installation script subprocess returned error exit status 9
Setting up nvidia-l4t-multimedia-utils (32.4.2-20200408182620) …
Setting up nvidia-l4t-oem-config (32.4.2-20200408182620) …
Setting up nvidia-l4t-tools (32.4.2-20200408182620) …
Setting up nvidia-l4t-wayland (32.4.2-20200408182620) …
Setting up nvidia-l4t-weston (32.4.2-20200408182620) …
dpkg: dependency problems prevent configuration of nvidia-l4t-x11:
nvidia-l4t-x11 depends on nvidia-l4t-init (= 32.4.2-20200408182620); however:
Package nvidia-l4t-init is not configured yet.

dpkg: error processing package nvidia-l4t-x11 (–install):
dependency problems - leaving unconfigured
Setting up nvidia-l4t-xusb-firmware (32.4.2-20200408182620) …
Pre-installing xusb firmware package, skip flashing
Setting up nvidia-l4t-kernel (4.9.140-tegra-32.4.2-20200408182620) …
Setting up nvidia-l4t-kernel-dtbs (4.9.140-tegra-32.4.2-20200408182620) …
Setting up nvidia-l4t-kernel-headers (4.9.140-tegra-32.4.2-20200408182620) …
Unpacking kernel headers…
Setting up nvidia-l4t-bootloader (32.4.2-20200408182620) …
Pre-installing bootloader package, skip flashing
dpkg: dependency problems prevent configuration of nvidia-l4t-3d-core:
nvidia-l4t-3d-core depends on nvidia-l4t-init (= 32.4.2-20200408182620); however:
Package nvidia-l4t-init is not configured yet.
nvidia-l4t-3d-core depends on nvidia-l4t-x11 (= 32.4.2-20200408182620); however:
Package nvidia-l4t-x11 is not configured yet.

dpkg: error processing package nvidia-l4t-3d-core (–install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nvidia-l4t-camera:
nvidia-l4t-camera depends on nvidia-l4t-3d-core (= 32.4.2-20200408182620); however:
Package nvidia-l4t-3d-core is not configured yet.

dpkg: error processing package nvidia-l4t-camera (–install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nvidia-l4t-cuda:
nvidia-l4t-cuda depends on nvidia-l4t-3d-core (= 32.4.2-20200408182620); however:
Package nvidia-l4t-3d-core is not configured yet.

dpkg: error processing package nvidia-l4t-cuda (–install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nvidia-l4t-graphics-demos:
nvidia-l4t-graphics-demos depends on nvidia-l4t-3d-core (= 32.4.2-20200408182620); however:
Package nvidia-l4t-3d-core is not configured yet.

dpkg: error processing package nvidia-l4t-graphics-demos (–install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nvidia-l4t-gstreamer:
nvidia-l4t-gstreamer depends on nvidia-l4t-camera (= 32.4.2-20200408182620); however:
Package nvidia-l4t-camera is not configured yet.
nvidia-l4t-gstreamer depends on nvidia-l4t-cuda (= 32.4.2-20200408182620); however:
Package nvidia-l4t-cuda is not configured yet.

dpkg: error processing package nvidia-l4t-gstreamer (–install):
dependency problems - leaving unconfigured
Setting up nvidia-l4t-initrd (32.4.2-20200408182620) …
Setting up nvidia-l4t-jetson-io (32.4.2-20200408182620) …
dpkg: dependency problems prevent configuration of nvidia-l4t-multimedia:
nvidia-l4t-multimedia depends on nvidia-l4t-3d-core (= 32.4.2-20200408182620); however:
Package nvidia-l4t-3d-core is not configured yet.
nvidia-l4t-multimedia depends on nvidia-l4t-cuda (= 32.4.2-20200408182620); however:
Package nvidia-l4t-cuda is not configured yet.

dpkg: error processing package nvidia-l4t-multimedia (–install):
dependency problems - leaving unconfigured
Processing triggers for nvidia-l4t-kernel (4.9.140-tegra-32.4.2-20200408182620) …
Errors were encountered while processing:
/opt/nvidia/l4t-packages/standalone/python3-jetson-gpio_2.0.8_arm64.deb
nvidia-l4t-init
nvidia-l4t-x11
nvidia-l4t-3d-core
nvidia-l4t-camera
nvidia-l4t-cuda
nvidia-l4t-graphics-demos
nvidia-l4t-gstreamer
nvidia-l4t-multimedia

Hi,
We are investigating this and will update the result.

BTW, I would like to know why you have to run apply_binaries.sh by yourself?
I don’t mean it is wrong but just think jetpack would help you do it in its installation.

Because I need to modify the linux kernel for the function on the carrier board that we designed ourselves.

1 Like

I think such request does not need to run apply_binaries.sh. What files do you need to update?

Add a driver for dimmer control and change some gpio’s configuration.

If you build it in Image, you could just put it under Linux_for_Tegra/kernel/

or if they are modules, you could install them to Linux_for_Tegra/rootfs/lib/modules/.

FYI, apply_binaries.sh just copies some files (more recently through packages, it is now “.deb” packages instead of loose tar files) into the “Linux_for_Tegra/rootfs/” content. Most of those apply_binaries.sh files go into “/usr/lib/aarch64-linux-gnu/tegra/”. Most of the actual root filesystem content is from a purely Ubuntu sample rootfs. The kernel Image itself is copied into “Linux_for_Tegra/rootfs/boot/” during flash, but is not related to apply_binaries.sh, nor are the kernel modules. There are some tegra libraries in the “/lib/modules/$(uname -a)/kernel/”, but those are not added via apply_binaries.sh.

If you change a module, then you just need to copy a file into the correct location under “/lib/modules/$(uname -r)/kernel/”. One option is to copy directly to the Jetson. Another option is to add to “Linux_for_Tegra/rootfs/lib/modules/$(uname -r)/kernel/” prior to a flash.

During a flash, on the PC side, the kernel Image file is copied in from “Linux_for_Tegra/kernel/Image”, and is placed at “Linux_for_Tegra/rootfs/boot/”. This can be copied directly into a Jetson, or placed in the kernel directory prior to a flash. Be careful to save a copy of the original version. You probably also want to save a copy of the running system’s “/proc/config.gz” prior to replacing a kernel Image. Be sure you set up your “CONFIG_LOCALVERSION” correctly before you compile your kernel Image.

Nothing in apply_binaries.sh will perform any file copy on the kernel Image, nor on the kernel modules, and these are where actual kernel space drivers go.

It seems the start of this error is nvidia-l4t-init. However, I tried another host but still get passed. Still need sometime to find the cause.

“dpkg: dependency problems prevent configuration of nvidia-l4t-x11:
nvidia-l4t-x11 depends on nvidia-l4t-init”

We find the cause. It seems a bug here when you use apply_binaries.sh in your second try.

Need sometime to get this fixed. Will update the thread when it is fixing.

Any solutions now?

This would be fixed in the deb file.

Hi WayneWWW
What do I need to do to solve this problem?
Best regrads!

Hi,

Either of this method should work.

  1. Need to wait for the deb file to be updated.
    or
  2. Remove " trusty" and “crypto” group in rootfs/etc/group and run apply_binaries.sh again.

Wayne, I am getting the same error with Jetpack 4.3 on a TX2 when I try to run sudo ./apply_binaries.sh I don’t have the “trusty” and “crypto” groups listed in rootfs/etc/group
Any other idea how to solve this?

@mtbsteve What is your error log? I guess you hit different issue.

Thanks for your quick reply. Here you go. The script always worked on Jetpack 4 and 4.2 before.

stephan@stephan-Aspire-A315-53:~/nvidia/nvidia_sdk/JetPack_4.3_Linux_JETSON_TX2/Linux_for_Tegra$ sudo ./apply_binaries.sh
    [sudo] password for stephan: 
    Using rootfs directory of: /home/stephan/nvidia/nvidia_sdk/JetPack_4.3_Linux_JETSON_TX2/Linux_for_Tegra/rootfs
    /home/stephan/nvidia/nvidia_sdk/JetPack_4.3_Linux_JETSON_TX2/Linux_for_Tegra/nv_tegra/nv-apply-debs.sh
    Root file system directory is /home/stephan/nvidia/nvidia_sdk/JetPack_4.3_Linux_JETSON_TX2/Linux_for_Tegra/rootfs
    Copying public debian packages to rootfs
    Start L4T BSP package installation
    QEMU binary is not available, looking for QEMU from host system
    Found /usr/bin/qemu-aarch64-static
    Installing QEMU binary in rootfs
    Installing Jetson OTA server key in rootfs
    ~/nvidia/nvidia_sdk/JetPack_4.3_Linux_JETSON_TX2/Linux_for_Tegra/rootfs ~/nvidia/nvidia_sdk/JetPack_4.3_Linux_JETSON_TX2/Linux_for_Tegra
    Registering Jetson OTA server key
    OK
    ~/nvidia/nvidia_sdk/JetPack_4.3_Linux_JETSON_TX2/Linux_for_Tegra
    Removing Jetson OTA server key from rootfs
    ~/nvidia/nvidia_sdk/JetPack_4.3_Linux_JETSON_TX2/Linux_for_Tegra/rootfs ~/nvidia/nvidia_sdk/JetPack_4.3_Linux_JETSON_TX2/Linux_for_Tegra
    Installing BSP Debian packages in /home/stephan/nvidia/nvidia_sdk/JetPack_4.3_Linux_JETSON_TX2/Linux_for_Tegra/rootfs
    (Reading database ... 120810 files and directories currently installed.)
    Preparing to unpack .../nvidia-l4t-ccp-t186ref_32.3.1-20191209230245_arm64.deb ...
    Pre-installing... skip compatibility checking.
    Unpacking nvidia-l4t-ccp-t186ref (32.3.1-20191209230245) over (32.3.1-20191209230245) ...
    Setting up nvidia-l4t-ccp-t186ref (32.3.1-20191209230245) ...
    (Reading database ... 120810 files and directories currently installed.)
    Preparing to unpack .../jetson-gpio-common_2.0.4_arm64.deb ...
    Unpacking jetson-gpio-common (2.0.4) over (2.0.4) ...
    Preparing to unpack .../python3-jetson-gpio_2.0.4_arm64.deb ...
    qemu: Unsupported syscall: 278
    Fatal Python error: failed to get random numbers to initialize Python

    qemu: uncaught target signal 6 (Aborted) - core dumped
    Aborted (core dumped)
    dpkg: warning: old python3-jetson-gpio package pre-removal script subprocess returned error exit status 134
    dpkg: trying script from the new package instead ...
    qemu: Unsupported syscall: 278
    Fatal Python error: failed to get random numbers to initialize Python

    qemu: uncaught target signal 6 (Aborted) - core dumped
    Aborted (core dumped)
    dpkg: error processing archive /opt/nvidia/l4t-packages/standalone/python3-jetson-gpio_2.0.4_arm64.deb (--install):
     new python3-jetson-gpio package pre-removal script subprocess returned error exit status 134
    Preparing to unpack .../python-jetson-gpio_2.0.4_arm64.deb ...
    Unpacking python-jetson-gpio (2.0.4) over (2.0.4) ...
    Preparing to unpack .../nvidia-l4t-3d-core_32.3.1-20191209230245_arm64.deb ...
    Unpacking nvidia-l4t-3d-core (32.3.1-20191209230245) over (32.3.1-20191209230245) ...
    Preparing to unpack .../nvidia-l4t-apt-source_32.3.1-20191209230245_arm64.deb ...
    Unpacking nvidia-l4t-apt-source (32.3.1-20191209230245) over (32.3.1-20191209230245) ...
    Preparing to unpack .../nvidia-l4t-camera_32.3.1-20191209230245_arm64.deb ...
    Unpacking nvidia-l4t-camera (32.3.1-20191209230245) over (32.3.1-20191209230245) ...
    Preparing to unpack .../nvidia-l4t-configs_32.3.1-20191209230245_arm64.deb ...
    Unpacking nvidia-l4t-configs (32.3.1-20191209230245) over (32.3.1-20191209230245) ...
    Preparing to unpack .../nvidia-l4t-core_32.3.1-20191209230245_arm64.deb ...
    Unpacking nvidia-l4t-core (32.3.1-20191209230245) over (32.3.1-20191209230245) ...
    Preparing to unpack .../nvidia-l4t-cuda_32.3.1-20191209230245_arm64.deb ...
    Unpacking nvidia-l4t-cuda (32.3.1-20191209230245) over (32.3.1-20191209230245) ...
    Preparing to unpack .../nvidia-l4t-firmware_32.3.1-20191209230245_arm64.deb ...
    Unpacking nvidia-l4t-firmware (32.3.1-20191209230245) over (32.3.1-20191209230245) ...
    Preparing to unpack .../nvidia-l4t-graphics-demos_32.3.1-20191209230245_arm64.deb ...
    Unpacking nvidia-l4t-graphics-demos (32.3.1-20191209230245) over (32.3.1-20191209230245) ...
    Preparing to unpack .../nvidia-l4t-gstreamer_32.3.1-20191209230245_arm64.deb ...
    Unpacking nvidia-l4t-gstreamer (32.3.1-20191209230245) over (32.3.1-20191209230245) ...
    Preparing to unpack .../nvidia-l4t-init_32.3.1-20191209230245_arm64.deb ...
    Unpacking nvidia-l4t-init (32.3.1-20191209230245) over (32.3.1-20191209230245) ...
    Preparing to unpack .../nvidia-l4t-initrd_32.3.1-20191209230245_arm64.deb ...
    Unpacking nvidia-l4t-initrd (32.3.1-20191209230245) over (32.3.1-20191209230245) ...
    Preparing to unpack .../nvidia-l4t-jetson-io_32.3.1-20191209230245_arm64.deb ...
    Unpacking nvidia-l4t-jetson-io (32.3.1-20191209230245) over (32.3.1-20191209230245) ...
    Preparing to unpack .../nvidia-l4t-multimedia_32.3.1-20191209230245_arm64.deb ...
    Unpacking nvidia-l4t-multimedia (32.3.1-20191209230245) over (32.3.1-20191209230245) ...
    Preparing to unpack .../nvidia-l4t-multimedia-utils_32.3.1-20191209230245_arm64.deb ...
    Unpacking nvidia-l4t-multimedia-utils (32.3.1-20191209230245) over (32.3.1-20191209230245) ...
    Preparing to unpack .../nvidia-l4t-oem-config_32.3.1-20191209230245_arm64.deb ...
    Unpacking nvidia-l4t-oem-config (32.3.1-20191209230245) over (32.3.1-20191209230245) ...
    Preparing to unpack .../nvidia-l4t-tools_32.3.1-20191209230245_arm64.deb ...
    Unpacking nvidia-l4t-tools (32.3.1-20191209230245) over (32.3.1-20191209230245) ...
    Preparing to unpack .../nvidia-l4t-wayland_32.3.1-20191209230245_arm64.deb ...
    Unpacking nvidia-l4t-wayland (32.3.1-20191209230245) over (32.3.1-20191209230245) ...
    Preparing to unpack .../nvidia-l4t-weston_32.3.1-20191209230245_arm64.deb ...
    Unpacking nvidia-l4t-weston (32.3.1-20191209230245) over (32.3.1-20191209230245) ...
    Preparing to unpack .../nvidia-l4t-x11_32.3.1-20191209230245_arm64.deb ...
    Unpacking nvidia-l4t-x11 (32.3.1-20191209230245) over (32.3.1-20191209230245) ...
    Preparing to unpack .../nvidia-l4t-xusb-firmware_32.3.1-20191209230245_arm64.deb ...
    Unpacking nvidia-l4t-xusb-firmware (32.3.1-20191209230245) over (32.3.1-20191209230245) ...
    Preparing to unpack .../nvidia-l4t-kernel_4.9.140-tegra-32.3.1-20191209230245_arm64.deb ...
    Unpacking nvidia-l4t-kernel (4.9.140-tegra-32.3.1-20191209230245) over (4.9.140-tegra-32.3.1-20191209230245) ...
    Preparing to unpack .../nvidia-l4t-kernel-dtbs_4.9.140-tegra-32.3.1-20191209230245_arm64.deb ...
    Unpacking nvidia-l4t-kernel-dtbs (4.9.140-tegra-32.3.1-20191209230245) over (4.9.140-tegra-32.3.1-20191209230245) ...
    Preparing to unpack .../nvidia-l4t-kernel-headers_4.9.140-tegra-32.3.1-20191209230245_arm64.deb ...
    Unpacking nvidia-l4t-kernel-headers (4.9.140-tegra-32.3.1-20191209230245) over (4.9.140-tegra-32.3.1-20191209230245) ...
    Preparing to unpack .../nvidia-l4t-bootloader_32.3.1-20191209230245_arm64.deb ...
    Pre-installing bootloader package, skip flashing
    Unpacking nvidia-l4t-bootloader (32.3.1-20191209230245) over (32.3.1-20191209230245) ...
    Setting up jetson-gpio-common (2.0.4) ...
    Setting up python-jetson-gpio (2.0.4) ...
    Setting up nvidia-l4t-apt-source (32.3.1-20191209230245) ...
    Pre-installing... skip changing source list.
    Setting up nvidia-l4t-configs (32.3.1-20191209230245) ...
    Setting up nvidia-l4t-core (32.3.1-20191209230245) ...
    Setting up nvidia-l4t-firmware (32.3.1-20191209230245) ...
    Setting up nvidia-l4t-init (32.3.1-20191209230245) ...
    Setting up nvidia-l4t-multimedia-utils (32.3.1-20191209230245) ...
    Setting up nvidia-l4t-oem-config (32.3.1-20191209230245) ...
    Setting up nvidia-l4t-tools (32.3.1-20191209230245) ...
    Setting up nvidia-l4t-wayland (32.3.1-20191209230245) ...
    Setting up nvidia-l4t-weston (32.3.1-20191209230245) ...
    Setting up nvidia-l4t-x11 (32.3.1-20191209230245) ...
    Setting up nvidia-l4t-xusb-firmware (32.3.1-20191209230245) ...
    Pre-installing xusb firmware package, skip flashing
    Setting up nvidia-l4t-kernel (4.9.140-tegra-32.3.1-20191209230245) ...
    Setting up nvidia-l4t-kernel-dtbs (4.9.140-tegra-32.3.1-20191209230245) ...
    /bin/ls: cannot access '*.dtb': No such file or directory
    Setting up nvidia-l4t-kernel-headers (4.9.140-tegra-32.3.1-20191209230245) ...
    Unpacking kernel headers...
    Setting up nvidia-l4t-bootloader (32.3.1-20191209230245) ...
    Pre-installing bootloader package, skip flashing
    Setting up nvidia-l4t-3d-core (32.3.1-20191209230245) ...
    Setting up nvidia-l4t-cuda (32.3.1-20191209230245) ...
    Setting up nvidia-l4t-graphics-demos (32.3.1-20191209230245) ...
    Setting up nvidia-l4t-initrd (32.3.1-20191209230245) ...
    Setting up nvidia-l4t-jetson-io (32.3.1-20191209230245) ...
    Setting up nvidia-l4t-multimedia (32.3.1-20191209230245) ...
    Setting up nvidia-l4t-camera (32.3.1-20191209230245) ...
    Setting up nvidia-l4t-gstreamer (32.3.1-20191209230245) ...
    Processing triggers for nvidia-l4t-kernel (4.9.140-tegra-32.3.1-20191209230245) ...
    Processing triggers for libc-bin (2.27-3ubuntu1) ...
    Errors were encountered while processing:
     /opt/nvidia/l4t-packages/standalone/python3-jetson-gpio_2.0.4_arm64.deb
    stephan@stephan-Aspire-A315-53:~/nvidia/nvidia_sdk/JetPack_4.3_Linux_JETSON_TX2/Linux_for_Tegra

Yes, this is different issue. Issue is even on jetpack4.4. We are still checking this one.

Thanks for looking into this. Pls let me know if you need any other infos.