Supported Drive OS versions on devkit revisions

Hi, is the list of supported Drive OS versions in the documentation here still up to date? We received P3710 940-63710-0010-D00 model devkits, and I see they’re still listed as requiring Drive OS and not supporting future versions (no “+” symbol).

I’m having trouble flashing one to 6.0.5, and I’m wondering if this is the issue.

Please provide the following info (tick the boxes after creating this topic):
Software Version
DRIVE OS 6.0.5
DRIVE OS 6.0.4 (rev. 1)

Target Operating System

Hardware Platform
DRIVE AGX Orin Developer Kit (940-63710-0010-D00)
DRIVE AGX Orin Developer Kit (940-63710-0010-C00)
DRIVE AGX Orin Developer Kit (not sure its number)

SDK Manager Version

Host Machine Version
native Ubuntu Linux 20.04 Host installed with SDK Manager
native Ubuntu Linux 20.04 Host installed with DRIVE OS Docker Containers
native Ubuntu Linux 18.04 Host installed with DRIVE OS Docker Containers

Dear @andrew.mcdonald,
Please see valid migration paths at Requirements for Your Development Environment

Thanks @SivaRamaKrishnaNV, so you’re confirming we cannot upgrade these devkits past It just says “no” in both rows. How do we access the latest features?

FWIW, I found the comment in the release notes about flashing issues, whose last bullet point was to try a USB2 port on the host computer. This worked fine for me and the process claims to have worked successfully. The only problem is that the username/password I supplied in the flashing process doesn’t work to log into the kit. Is that specifically the bit that’s known not to work when upgrading? Also, since the flashing procedure should be able to read the existing version on the devkit before proceeding, could it check for this and alert the user before flashing?

Dear @andrew.mcdonald,
I will double check the migration path internally and confirm.

So, Do you see flashing is successful message in sdkmanager when tried installing 6.0.5? If not, can you check 6.0.4 first? Also, please attach the flashing logs for reference(~/.nvsdkm/sdkm*.log and ~/.nvsdkm/logs)

Hi @SivaRamaKrishnaNV; yes, I do see the “installation completed successfully” message in SDK Manager with 6.0.5. Here are the exported logs. (2.9 MB)

The devkit then boots up fine, but I can’t log in with the credentials supplied at flashing time. I’ll go back to 6.0.4 and try that.

Hello @SivaRamaKrishnaNV, is there any update on this? I’m still wondering about the supported workflows, as the info in that document is a little confusing. Since the idea of flashing is to completely overwrite what’s on the devkit (even the persistent data - we’ve nothing we need to preserve there), I’m hoping it shouldn’t matter what was on there before.

Dear @andrew.mcdonald,
We have not tested DRIVE OS 6.0.3 → DRIVE OS 6.0.5.
We always recommend to upgrade to next release from current release.

Did you try DRIVE OS 6.0.4 using sdkmanager?

If login is the issue, how about changing the username and password similar to linux(Host/Target Setup and Configuration | NVIDIA Docs)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.