SX6025 unmanaged switch firmware update

Hello

We have a bunch of MT/HP_1010xxxxx SX6025 unmanaged switches with old firmware that we would like to update to latest

Sadly none of the known to me fw burning tools works and returns “MFE_UNSUPPORTED_DEVICE” or similar

root@XXX:/tmp# mlxburn -d /dev/mst/SW_MT51000_SwitchX_-_Mellanox_Technologies_lid-0x01e6 -i fw-SX-rel-9_4_1000-MSX6025F-xxxS_Ax.bin
FATAL - Can’t find device id.
-E- Can not auto detect device type: 41. Please check the given device.
Error: (‘Can not auto detect device type: 41. Please check the given device.’, 1). Exiting…
root@XXX:/tmp# mstflint -d /dev/mst/SW_MT51000_SwitchX
-_Mellanox_Technologies_lid-0x01e6 -i fw-SX-rel-9_4_1000-MSX6025F-xxxS_Ax.bin b
-E- Cannot open Device: /dev/mst/SW_MT51000_SwitchX
-_Mellanox_Technologies_lid-0x01e6. Function not implemented. MFE_CR_ERROR
root@XXX:/tmp# flint -d /dev/mst/SW_MT51000_SwitchX
-_Mellanox_Technologies_lid-0x01e6 -i fw-SX-rel-9_4_1000-MSX6025F-xxxS_Ax.bin burn
FATAL - Can’t find device id.
-E- Cannot open Device: /dev/mst/SW_MT51000_SwitchX
-__Mellanox_Technologies_lid-0x01e6. MFE_UNSUPPORTED_DEVICE
root@XXX:/tmp#

Anyone knows how to overcome it ? Maybe another tool or older version of a tool should be used ?

Thank you in advance!
Regards,
Vladimir

Hello,

Please try the steps below.

  1. Run the “mst start command”

  2. Run the “mst ib add” command .

  3. ibswitches to get LID/GUID info
    Example:
    [root@l-csi-0740s ~]# ibswitches
    Switch : 0x98039b03006b9564 ports 41 “MF0;l-csi-8700-02:MQM8700/U1” enhanced port 0 lid 0 lmc 0
    Switch : 0x98039b0300cb96c0 ports 41 “Quantum Mellanox Technologies” base port 0 lid 103 lmc 0

  4. Query the lid to check the FW and PSID:
    Example:
    [root@l-csi-0740s ~]# flint -d lid-103 q
    Image type: FS4
    FW ISSU Version: 1
    FW Version: 27.2008.2500 <<<<<<
    FW Release Date: 10.3.2021
    Description: UID GuidsNumber
    Base GUID: 98039b0300cb96c0 32
    Base MAC: 98039bcb96c0 32
    Image VSD: N/A
    Device VSD: N/A
    PSID: MT_0000000063 <<<<<
    Security Attributes: N/A

  5. Burn the FW using the following syntax, but use the HEX value of the LID:

flint -d lid- -i b

EXAMPLE:
[root@l-csi-0740s tmp]# flint -d lid-0x0067 -i fw-Quantum-rel-27_2008_2402-MQM8790-HS2X_Ax.bin b
Done.
Current FW version on flash: 27.2008.2500
New FW version: 27.2008.2402

Note: The new FW version is older than the current FW version on flash.

Do you want to continue ? (y/n) [n] :

  1. Reset the switch:

[root@l-csi-0740s tmp]# flint -d lid-103 swreset
-I- Sending reset command to device lid-103 …
-I- Reset command accepted by the device.

If still issues, please open a case with Nvidia Support

Thanks Kevin
Still same error when using the lid ( both decimal and hexadecimal) , I will try to check with the NVidia support

Regards,
Vladimir

Hi,

What MFT version are you using? Since 4.21.0 we seem to have removed support for SwitchX devices (among other EOL devices).

Have you tried older MFT versions?

Hi @dwaxman
Sorry for delayed reply - I was out of office

You suggestion worked - after downgrading MFT to 4.20.0-34 I could query the switches with flint

XXX@XXXX:~/mft-4.20.0-34-x86_64-deb# mst version
mst, mft 4.20.0-34, built on Apr 25 2022, 20:48:31. Git SHA Hash: 62bbc33
XXX@XXXX:~/mft-4.20.0-34-x86_64-deb# flint -d /dev/mst/SW_MT51000_SwitchX_-__Mellanox_Technologies_lid-0x010F q
Image type:            FS2
FW Version:            9.3.0000
FW Release Date:       21.10.2014
Device ID:             51000
Description:           Node             Port1            Port2            Sys image
GUIDs:                 f452140300f73ff0 0000000000000000 0000000000000000 f452140300f73ff0 
MACs:                                       f45214f73ff0     f45214f74050
VSD:                   n/a
PSID:                  HP_1010110021

Thanks a lot, it was very helpful !
Regards,
Vladimir

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.