System doesn't use Nvidia Gpu

OS: Kubuntu 22.04 LTS x86_64
Host: Asus TUF f15 FX506LH
Kernel: 5.17.5-76051705-generic
GPUs: Intel CometLake-H GT2 and nvidia gtx 1650

problem: System doesn’t properly see nvidia GPU, neofetch displays the GPU as “NVIDIA 01:00.0”, both steam and standalone games don’t use nvidia. Im using driver (510.73.05], on 470 it didn’t work either. I tried using older kernel but it also didn’t work.

Here is nvidia-smi output:

| NVIDIA-SMI 510.73.05    Driver Version: 510.73.05    CUDA Version: 11.6     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|   0  NVIDIA GeForce ...  Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   41C    P8     1W /  N/A |      5MiB /  4096MiB |      0%      Default |
|                               |                      |                  N/A |
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|    0   N/A  N/A      5343      G   /usr/lib/xorg/Xorg                  4MiB |

here is nvidia-settings output:

(nvidia-settings:9909): GLib-GObject-CRITICAL **: 21:48:14.103: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
** Message: 21:48:14.173: PRIME: Requires offloading
** Message: 21:48:14.173: PRIME: is it supported? yes
** Message: 21:48:14.203: PRIME: Usage: /usr/bin/prime-select nvidia|intel|on-demand|query
** Message: 21:48:14.203: PRIME: on-demand mode: "1"
** Message: 21:48:14.203: PRIME: is "on-demand" mode supported? yes

I’ll paste nvidia bug report in the comment.

I checked a ton of forum posts. non seem to describe a similar problem nor do they provide any solutions that would help me.

nvidia-bug-report.log (2.1 MB)

You’re in offload aka on-demand mode. You’ll have to explicitly tell applications to run on the nvidia gpu:

If you want everything to run on the nvidia gpu, use
sudo prime-select nvidia
and reboot.

  1. It looks like on demand mode but no matter how i try it, via sudo prime-select, via nvidia-settings or via making an app load using nvidia it didn’t work.

I reinstalled the system and it worked, i don’t have a clue what could have broke it becouse fresh install got every update that was on the broken one and i loaded a backup and it is still working.
Thanks for the help tho.