Temporary black screen over and over fedora 37 and nvidia 520.56.06

I have just installed Fedora 37 and the nvidia 520.56.06 driver and I keep getting a black screen and a few seconds later it goes back to normal. This does not happen on windows so I do not believe that it is the graphics card its self. It mostly seems to happen a few seconds after turning of some graphically intense application or when I am first getting logged into gnome. I have been looking for a way to try to stop this behavior but I have not found much. Can someone help me troubleshoot this issue? I am on linux kernel version 6.0.12-300. If any other information would be useful please let me know and I can gladly collect it.
nvidia-bug-report.log.gz (418.1 KB)

Side note that I am noticing is this issue has not happened once when I am playing a game or doing something more intense for my gpu. Maybe this has something to do from swapping from a high power to lower power profiles?

Sounds like my bug. Please see my bug report:

No one has helped. When I reverted to 510 the bug went away for months. But I just upgraded to Fedora 36 and 510 won’t compile anymore(?). I’m stuck with 520 and like you 520 always has this bug.

Luckily it’s just my 3rd monitor and I can just turn it off. Are you using multi-monitor? Any DP daisychaining?

Your theory about power profiles is intriguing. I tried changing nvidia-settings power levels to “high performance” but it didn’t really help. I loaded up supertuxcart and when I first started it the bug seemed to go away for 30s or so, but then came back. Not sure if it was a fluke. Subsequent loads don’t seem to help.

Any FLOSS (best if in easy stock Fedora rpm) “graphically intense” things you can recommend I try? Maybe supertux wasn’t intense enough.

Any ideas on how to tweak power profiles to test more?

I noticed that too. When I first startx (XFCE with sawfish WM) the bug does not start for a little bit. Maybe 20-30s. After that, it’s basically every 1 to 10s.

I wonder why it “waits” while our desktop environments are “warming up”.

Yes I do have multiple monitors but for me it happens on all of them. The game I was testing with was world of warcraft through lutris. When I am running something graphically intensive this issue NEVER happens. It mostly seems to happen for me when swapping from a high gpu task to a low gpu task, and when starting the computer. I was able to play my game for almost 5 hours yesterday with no issues but the blanking happened three times as soon as I killed the game. As a side note I am using dp on both of my monitors.

Looks like you have 2 1920 monitors both in landscape? The bugreport doesn’t seem to tell the brand/model. What’s the brand? Mine are Dell. My 2 Ultrasharps don’t have the bug, just the P series monitor, but it’s the only one on DP daisy chain.

Are you daisy-chaining the 2nd DP monitor (only 1 cable goes to the computer for both monitors)?

When it goes black do both monitors go black at the same time?

Also, you make it sound like it only happens a few times after loading the OS or quitting a game?? Or does it happen a lot after you do those things (i.e. keep blanking until you start up another game). Mine is constant.

Looks like you’re using Wayland. I’m using Xorg only. Helps to eliminate things. I’m still trying to find an intensive game to test with, I don’t really game much, and all my Steam games are low-intensity strategy.

Hmm, looking for more similarities: we both are using Ryzen. Though your MSI board is 1 gen newer than my Asrock board. Your card is 1070, mine 1650. I know Ryzen boards sometimes need power/sleep state bios tweaks to be stable in linux. Have you applied any of those tweaks?

I have never had too. This system has always just worked with linux. I do have 2 monitors in landscape and both of them are dell E2417H monitors. I have 2 dp cables one for each monitor. When the screen goes black both of them go black at the same time and can happen multiple times but it does have an end. When my computer comes back from sleeping, stopping an intensive game, starting gnome from a reboot, or stuff like that. It will flicker to black a few times then it seems to correct its self. I am using wayland

I experience this as well. 2 4k 60hz monitors one 1080p 60hz in landscape, all DP but not chained. RTX 3060 and Ryzen on MSI B550-A Pro. Fedora 37, 6.0.12 kernel. 520.56.06 driver.

It seems to only happen to the right two monitors. The 1080p monitor (furtherest right) has my keyboard and mouse plugged in and if I physically turn it off they disconnect. That doesn’t happen when the screen goes blank and the display settings don’t rearrange like they do either so I think the screen acting differently from not being detected.

Annecdotally both the right screens can go black but it’s almost never at the same time. It mostly happens when my mouse is doing something on the screen like clicking a tab or button (adding extra annoyance) initially but then can “spread” to the other screen and sometimes goes back and forth.

nvidia-bug-report.log.gz (500.3 KB)

I think I am just going to swap back to windows on this machine. I am not willing to wait a super long time to get this issue fixed. I hope the logs I submitted are useful.