Black screen on multi-monitor setup on Xorg with driver > 525.60.11


I have a laptop using and AMD CPU+GPU and a discrete NVIDIA GPU.
In very short, I have this setup:

Monitor 2 ← DP cable → Monitor 1 ← USB C → Laptop

When using Xorg and a newer version of the driver > 525.60.11, Monitor 1 does not work.

The behavior is very strange. If I disable monitor 2, monitor 1 works.
Re-enabling monitor 2 makes monitor 1 show a partial frame.
Then, the two of them stop working at random while making the other work. Sometimes.

I really cannot figure out what is the issue at all.

Running Wayland has no issue, the monitors work perfectly.
It is just that Plasma is not very Wayland-friendly and a bit unstable.

I am attaching the log generated from the “nvidia-log-report” script.

Other information that can be useful
OS: ArchLinux, all packages up to date
Desktop Environment: Plasma 5.27, happens also in GNOME
Kernels: Both 6.1.19 LTS and stable 6.2.6

Current workaround
Downgrade the driver to 525.60.11.
The driver however does not work with the stable kernel, only the LTS one.

Let me know if I can provide more information!
nvidia-bug-report.log.gz (2.1 MB)

While the symptoms are completely different, I suspect your issue to have the same reason as this:
DisplayPort bandwidth too low.

Hi @generix,

I appreciate your input.
I looked quickly through the thread and the main difference is that Wayland for me works with no issue.
It might be that the driver misbehaves with clocks only in Xorg…?

I can try the “Prefer maximum performance” trick and report back.

Would you like me to gather other information?

Quick update:
Setting the NVIDIA card mode to “Prefer maximum performance” via NVIDIA X Settings still has the middle screen as black.

It seems however that, sometimes, disabling and enabling the middle screen gets to work.
It involves disabling all external monitors, then enabling monitor 2 and then monitor 1.
The mode needs to be maximum performance and this won’t survive a reboot AKA this disabling and enabling process need to be reapplied.