Diagonal Screen Tearing since 525.78.01 - Thinkpad P1 Gen2 T2000

Since updating the Nvidia driver to I am experiencing a diagonal screen tearing on my external Monitor Thinkvision P27u running either via USB-C DP alt mode, HDMI or connected via Thunderbolt Workstation Dock Gen2 Display Port. Same issue with a or Dell S7271QS via HDMI or Display Port via Thunderbolt Workstation Dock Gen2.

Notebook: Thinkpad P1 Gen2
The GPU is a T2000
OS: Fedora 37
Drivers not working so far: 525.78.01, 525.85.05, 525.89.02
Last driver working: 525.60.11

I am experiencing the same issue with the nouveau drive as weel since day one. It is just the other diagonale and appears even for example when scrolling web sites, open new tabs, etc…

Since Nvidia driver 525.78.01 the exact same problem appears.
The most easiest to reproduce the issue was to simply show the sleep/reboot/shutdown/log off screen

Video of the issue:

Anyone else experiencing the same issue?

Nvidia bug report attached
nvidia-bug-report.log.gz (133.7 KB)

I have same issue on my Optimus device. I have tearing problem while using XWayland applications on Wayland server with PRIME Render Offload. 520 drivers just works fine.

Enabling Performance Mode and using Weston as compositor solves my issue for now.

I am experiencing this issue with Xserver, because Wayland is so laggy that it is unusable with the nvidia driver

@aplattner @amrits
any feedback from your side?

Does setting “prefer maximum performance” in nvidia-settings change anything?

Indeed, the tearing is gone.

Now is the question, what was changed from 525.60.11 that caused this issue?

Nevertheless, this can not be the solution to run the Nvidia Quadro T2000 all the time in performance mode. This is a portable machine.

Any idea what causes the issue?

@aplattner @amrits
I am still waiting for your feedback to this issue

Looks like you are forcing us (University IT department) to completely switch from Nvidia CUDA.
We can not use it anyway when drivers are not working properly.

I suspect this is a fallout from nvidia changing their clocking algorithm trying to mitigate high power consumption with multi-monitor setups (check the forum for posts from users complaining about it). For your setup, the memory clocks are likely now too low to provide the needed memory bandwidth/latency.
Instead of using max performance, you could check whether your gpu supports nvidia-smi -lgc to manually just set a higher minimum memory clock.
Edit: I meant nvidia-smi -lmc for memory clocks.

I checked the change log of 525.78.01 and found the following:

Could be that this “fix” causes the new issue.
Surprisingly the problem also appears when not running in “Reverse Prime” but also in regular “Prime”.

@amrits @aplattner
Could you please take care of this issue and fix it.
Even when scrolling in texts, this is really unusable and extremely distracting.
Don’t get me wrong, but the the Nvidia Quadro T2000 was a quite powerful mobile graphic chips and by introducing this change, it turns into showing garbage, almost impossible to not get distracted from work with 3500$ machines

During experiencing massive screen tearing I checked

nvidia-smi dmon

and did not see any signifigance differene in clockspeeds between driver versions 525.65.01 (no tearing) and 525.89.02 (massive tearing), but see for yourself

Driver 525.89.02

Driver 515.65.01

I have filed a bug 4004122 internally for tracking purpose.
I will check for similar hardware internally and try for local repro.
Can you please confirm if issue is only reproducible with dock connected?

Thanks for taking care.
Issue is reproducible also without dock connected, so completely independent from dock.

I tried with a 4K monitor directly connected to laptop via HDMI or USB-C (so dock disconnected)
Also tried with a 4K monitor via Display Port with dock connected via thunderbolt

In any cases massive tearing.

Could you find similar hardware to reproduce the issue?
(I remember you had a Thinkpad P1 Gen3 here: External Monitor not available after Suspend/Sleep - #32 by amrits)

2 Weeks later and still no reply.

Could you find similar hardware to reproduce the issue?

Apologize for the late response.
I tried on couple of Thinkpad notebooks (ThinkPad P1 Gen 3 and ThinkPad P1 Gen 5) but did not observe any flickering/tearing issue so far.
I will spend few more cycles on it and update.
Are you seeing this issue consistently or happen after certain amount of time post boot ?

The issue is consistently on every boot, independent of time past after boot.

Reducing resolution to FullHD 1080p helps to reduce the issue
with monitors native resolution 4k the issue is much worse than with FullHD

The issue is best visible with changing gradients like opening the sleep/restart/shutdown dialog in KDE Plasma wih X11 (Wayland is so laggy that it is totally unusable)

issue persists with driver version 530.30.02

issue persists also with version 530.41.03

issue still persists with version 525.105.17
issue still not there with version 515.105.01

could you please try the following:
The issue is best visible with changing gradients like opening the sleep/restart/shutdown dialog in KDE Plasma wih X11 (Wayland is so laggy that it is totally unusable) on an external 4k monitor

Unbelievable, 2 months and still no reaction to my findings.

Problem is still present with 535.43.02 Beta.

Do you now only focus on AI in the server field?
If the problem is not solved within the foreseeable future, we’ll dump all Nvidia hardware and switch to Intel. Seems like Nvidia is just useless in the Accademic area - Vienna University of Technology

We do have local repro now further investigation.
Engineering team is currently debugging the issue.