TensorRT for Python3.8 Jetson Nano python bindings

Hello, I am trying to use TensorRT on Python3.8 on my Jetson Nano. I used SDK manager to get Jetpack for Jetson Nano, however that installs the bindings to Python3.6. I can use TensorRT on 3.6, but I’d like to use it on 3.8. I have been using this forum as a reference:

However, a deb file for the ’ Add PyConfig.h’ step for Python3.8 is not located at the linked website here. Instead, I use the pyconfig.h file that I have in my aarch64 install of Python3.8, which I assume is acceptable, but I still have not had success. Thank you.

Hi,

The file seems removed.
Let us check this internally and update later.

Thanks.

Hi,

Since PyConfig.h is a third-party library, we are not able to provide Python 3.8 for the aarch64 environment.
Please stay on Python 3.6 or use other devices that can upgrade to a newer JetPack version.

Thanks.

Okay. In that case, I will not be able to use this to build the tensorrt bindings for Python3.8 as mentioned here?:

Hi,

To build the pybinding, you will need the PyConfig.h for Python 3.8+aarch64.
Since it’s a third-party library, we cannot provide it here.

But you can still search if there is any archive file online.

Thanks.

Hi,

Found an official link from Ubuntu:

Then you can follow the steps shared below to build the python binding.
(please replace python3.9 to python3.8)
https://elinux.org/Jetson/L4T/TRT_Customized_Example#TensorRT_Python_Bindings

Thanks.