tesla c2075 faild

I purchased the following cards from b&h
quadro 4000
tesla c2075
for the Maximus Technology

I am a video editor and After Effects animator

I built the computer.
And when I turned it to install windows
Computer froze in the first frame (motherborad logo), Instead of entering the BIOS.

I took the Tesla out and the computer works.

i installd windows, quadro works fine and then i inserted the tesla and again nothing (the same problem).

i took out the quadro and install only the tesla, nothing, froze on motherboard logo again.

PC Specs:

Motherboard Gigabyte GA-X79-UD5
Tesla C2075 6 GB GDDR5 PCIe Computing Processor
nVIDIA Quadro 4000 Display Card
Core i7-3930K 3.20 GHz Processor
32 gb memory (8*4)
antec 850w power


Make sure you’re plugging in the PCI-E power connectors on the Tesla board.
Also, upgrade your motherboard BIOS, and try plugging in the Tesla card again.

If it still doesn’t work, try the Tesla card on another system. If that still doesn’t work, you have a defective card, RMA it. If it works, you might have to seek support for your BIOS manufacturer to see why the card is not posting – if it gets to that, and you know the Tesla card works, I’d RMA the motherboard instead and get a different one (assuming you can, that is, I re-read and you just recently purchased the cards)


I got a similar issue, same motherboard but with a EVGA-GTX-760. I upgraded the bios to version F12,
but nothing.

PC Specs.

Motherboard Gigabyte GA-X79-UD5
32 gb memory (8*4) (Corsair Vengance)
Corsair 1200 W power
Core I7 3820, 3.6 Ghz quad core



Remove Quadro and try install Tesla C2075 again. If it works, please ask supports from motherboard manufacturer.

Like ryluo said, if updating to the latest BIOS and changing slots on the motherboard doesn’t work, it may be time to return the motherboard assuming it is a recent purchase and going with another manufacturer. Do however check that the graphics cards are not the problem – test them on another system and follow the advice I already gave the original poster.

It would seem that the motherboard BIOS is at fault, since that is the underlying common factor, especially if the cards are the same… you might want to seek support from the motherboard vendor ASAP on that.

Edit: It seems that they have a beta BIOS F13p for your Motherboard:

You might want to try that and see if it solves the problem before you contact their support.