Tesla T4, Ubuntu 20.04, NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver

Following a fresh install of 20.04, I ran the following:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt install nvidia-driver-460

I’ve tried both 460 and 470, using the ppa and without it. In either case I have to use prime-select to switch from nvidia to intel (not sure why it tries to select nvidia since the Tesla T4 has no display capabilites). If I don’t use prime-select intel, the machine boots to a blank screen.

I’ve reviewed several of the posts here regarding this error and cannot find anything that solves it. any help is appreciated!

$ uname -r

$ dkms status
nvidia, 460.91.03, 5.11.0-37-generic, x86_64: installed

nvidia-bug-report.log.gz (82.2 KB)

There is no sign of the driver trying to load.
Please first try sudo update-initramfs -c -k all and reboot.
If that doesn’t work, please switch to nvidia with sudo prime-select and then reboot. If you get a black screen, try to switch to a virtual console (Ctrl+Alt+F3) and run nvidia-bug-report.sh as root.
If you don’t get a console, reboot and run journalctl -b1 >kernel.txt and upload that file.

Thanks for pointing me in the right direction! After a few more steps I was able to get this working. After update-initramfs, there was no change. I then ran:

$ sudo prime-select nvidia

After a reboot, it went to a black screen again. I used ctrl-alt-f3 to get to the console. I was then able to run nvidia-smi and the driver was loaded correctly. I then assumed the problem is that it is trying to use the Tesla T4 as the display device.

Afterwards, I found instructions on how to use the integrated graphics unit on Ubuntu 20.04, and everything is working:


$ sudo prime-select on-demand

Then, I followed the instructions here to select the intel: