The IMX390-GMSL2 camera module cannot be lit with jetson agx orin in Linux 36.2.0

Hi:
I tried to adapt the imx390-gmsl2 camera module on Linux36.2.0. The driver was loaded successfully and the correct frame rate was printed using the v4l2-ctl command. As shown in the picture below:
image
After this, I used the dmesg command to view the log when printing the frame rate, the specific information is shown below:


Then I executed the argus_camera -d 0 command, and argus also got an error. The error message is as follows:

Below is the trace log of printing frame rate, I hope you can give me some advice and help, thank you very much!
trace.txt (6.9 MB)

The log show “no camera available” that could be the incorrect context of tegra_camera_platform{} special the devname in modules.

Thanks

The following is the node information I configured. Can you help me see where the problem came out?

What’s the below command shows.

v4l2-ctl --all

The following information is displayed after v4l2-ctl --all is executed:


Confirm the devname is “imx390 30-001b” by below command.
If without problem get the daemon log by “journalctl -f -u nvargus-daemon”

/proc/device-tree/tegra-camera-platform/modules/module0/drivernode0/devname

The devname information I checked was indeed “imx390 30-001b”. When I run journalctl -f -u nvargus-daemon, I see the daemon log as shown below:

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.
Thanks

Did you have any modify for the imx390 kernel driver or device tree for the sensor mode?