The screen flickers when viewed from a distance

I find that,when I set cxrDeviceDesc videoStreamDescs’s width & height, and the maxResFactor to normal 1.2, the frame latched with cxrLatchFrame will have a larger size。

When I open the system window and move my position back by about 1 meter, the system window flickers a bit, especially with text. (the background looks good). Is this related to mipmaps? Is the mipmap enabled for the frame latched from the server? Are there any settings or methods to minimize this phenomenon?

The closer my eyes are to the system window, the less noticeable the flickering phenomenon becomes.

I don’t see anything particularly wrong in the screenshot you posted. If you see something I’m not, can you mark it on the image and describe?

Alternately: Does a video capture show the phenomenon, or is it only apparent while wearing the headset? If video capture does show it, can you post?

The behavior you describe with maxResFactor and width/height is expected. In many cases, it is advantageous to over-render XR content, because it will be reprojected and not pixel-exact on the screen. The frame latched with cxrLatchFrame should be 1.2x the provided width/height. If not, could you provide details? If you want to control resolution exactly, you can set that value to 1.0.

Have you played with the foveation parameter? It vastly improves bandwidth usage to foveate the frames, but there is a quality cost. You might try foveation at 100%, which does not foveate before/de-foveate after streaming.

Sorry, the static picture did not show the problem, I’ve record the hmd screen with a video.
At the beginning, the window is close to eye and the texts is normal. After setting a remote position, texts flicker a bit, especially the small text in the top right.
I also tried to set foveation at 100%, it seems not help.

I see the issue, and it is frustrating. Text and VR is hard, and double so with streaming. Does this issue show up “locally” in SteamVR, and/or have you tried other streaming systems like Oculus AirLink or VIVE’s local streaming? If you can confirm that one or more of these situations does not cause the problem, it would help.

One thing to try is to increase the streaming resolution, either with the resolution factor or with the actual width/height. Another thing to try is to increase the streaming maxBitrate parameter, to try to increase the quality of the video stream.

You might also try increasing the fps, if that’s a factor. If you can share, what HMD are you using and what have you set the parameters to?