TimeoutError when installing with pip

Hello.
I am trying to install the python libraries needed for TensorRT python samples (on Jetson Xavier).
“python3 -m pip install -r requirements.txt”
I constantly get the following error:
"'ReadTimeoutError(“HTTPSConnectionPool(host=‘pypi.org’, port=443): Read timed out”

In addition tried with pip3(didn’t help)
Also increased the default timeout (using --default-timeout=500)and still got these errors
I don’t have problems to access the python website via the regular browser. I also checked network definitions and in the proxy section the method is “none”

No others ideas left. Maybe you could help me

Best regards

Someone solved this issue to disable IPV6 from here:

sudo sysctl -w net.ipv6.conf.all.disable_ipv6=1
sudo sysctl -w net.ipv6.conf.default.disable_ipv6=1
1 Like

Thanks a lot!!! This actually works!

I got the exact same TimeoutError when installing with pip, but the suggested solution didn’t solve the problem for me. It just replaced the error I get with a different one:

raise HTTPError(http_error_msg, response=self)
requests.exceptions.HTTPError: 404 Client Error: Not Found for url: https://pypi.org/simple/python3-opencv/

Any ideas?

Thanks a lot!

Hello @nmiron7

Maybe you can upgrade your pip:
$ python3 -m pip install --upgrade pip

Someone solved the

error from here

Regards

Have you checked proxy settings? When I had this problem one of the answers I found in stackoverflow relates to this

Hello @marinak and @mehmetdeniz and thank you for your replies
Unfortunately neither solutions worked for me.

@mehmetdeniz you suggested upgrading my pip, but I cannot upgrade anything using pip (not even pip itself), since I get the same TimeoutError

@marinak I tried the solution with the proxies, using this code:
python3 -m pip --proxy http://user:pass@server:port install python3-opencv

From which I have gotten the following error:

Collecting python3-opencv Exception: Traceback (most recent call last): File "/usr/lib/python3/dist-packages/pip/basecommand.py", line 215, in main status = self.run(options, args) File "/usr/lib/python3/dist-packages/pip/commands/install.py", line 353, in run wb.build(autobuilding=True) File "/usr/lib/python3/dist-packages/pip/wheel.py", line 749, in build self.requirement_set.prepare_files(self.finder) File "/usr/lib/python3/dist-packages/pip/req/req_set.py", line 380, in prepare_files ignore_dependencies=self.ignore_dependencies)) File "/usr/lib/python3/dist-packages/pip/req/req_set.py", line 554, in _prepare_file require_hashes File "/usr/lib/python3/dist-packages/pip/req/req_install.py", line 278, in populate_link self.link = finder.find_requirement(self, upgrade) File "/usr/lib/python3/dist-packages/pip/index.py", line 465, in find_requirement all_candidates = self.find_all_candidates(req.name) File "/usr/lib/python3/dist-packages/pip/index.py", line 423, in find_all_candidates for page in self._get_pages(url_locations, project_name): File "/usr/lib/python3/dist-packages/pip/index.py", line 568, in _get_pages page = self._get_page(location) File "/usr/lib/python3/dist-packages/pip/index.py", line 683, in _get_page return HTMLPage.get_page(link, session=self.session) File "/usr/lib/python3/dist-packages/pip/index.py", line 792, in get_page "Cache-Control": "max-age=600", File "/usr/share/python-wheels/requests-2.18.4-py2.py3-none-any.whl/requests/sessions.py", line 533, in get return self.request('GET', url, **kwargs) File "/usr/lib/python3/dist-packages/pip/download.py", line 386, in request return super(PipSession, self).request(method, url, *args, **kwargs) File "/usr/share/python-wheels/requests-2.18.4-py2.py3-none-any.whl/requests/sessions.py", line 520, in request resp = self.send(prep, **send_kwargs) File "/usr/share/python-wheels/requests-2.18.4-py2.py3-none-any.whl/requests/sessions.py", line 630, in send r = adapter.send(request, **kwargs) File "/usr/share/python-wheels/CacheControl-0.11.7-py2.py3-none-any.whl/cachecontrol/adapter.py", line 47, in send resp = super(CacheControlAdapter, self).send(request, **kw) File "/usr/share/python-wheels/requests-2.18.4-py2.py3-none-any.whl/requests/adapters.py", line 405, in send conn = self.get_connection(request.url, proxies) File "/usr/share/python-wheels/requests-2.18.4-py2.py3-none-any.whl/requests/adapters.py", line 303, in get_connection proxy_manager = self.proxy_manager_for(proxy) File "/usr/share/python-wheels/requests-2.18.4-py2.py3-none-any.whl/requests/adapters.py", line 197, in proxy_manager_for **proxy_kwargs) File "/usr/share/python-wheels/urllib3-1.22-py2.py3-none-any.whl/urllib3/poolmanager.py", line 449, in proxy_from_url return ProxyManager(proxy_url=url, **kw) File "/usr/share/python-wheels/urllib3-1.22-py2.py3-none-any.whl/urllib3/poolmanager.py", line 394, in __init__ proxy = parse_url(proxy_url) File "/usr/share/python-wheels/urllib3-1.22-py2.py3-none-any.whl/urllib3/util/url.py", line 207, in parse_url raise LocationParseError(url) urllib3.exceptions.LocationParseError: Failed to parse: server:port

Any insights?

Thanks again!

Unfortunately I don’t know. In my case, I just saw that proxy is not used in my web settings. So I eliminated this issue. However, I don’t know how to solve the issue it when proxy is used.