Tried to remove CUDA9 for 8 but get unmet dependency errors

I have tried many forums, solutions, etc. But no atter what I do, I am blocked this:

The following packages have unmet dependencies:
cuda-cublas-dev-9-1 : Depends: cuda-cublas-9-1 (>= but it is not going to be installed
cuda-libraries-9-1 : Depends: cuda-cublas-9-1 (>= 9.1.85) but it is not going to be installed
E: Unmet dependencies. Try ‘apt-get -f install’ with no packages (or specify a solution).

I have tried many versions of purge, remove, etc. I have tried different versions of python and even tried to hunt down and remove the CUDA 9 files manually.

…well, not a solution but I am hoping this worked: out of the blue, a window popped up asking if I would like to do a partial update. Yeah, why not, at this point I can’t upgrade and I am considering reinstalling ubuntu.

now, for the first time in a week, when I run sudo apt-get upgrade, it runs to completion.

why that little window popped up, I have no clue. I had given up and was reading a paper when I noticed it.

che culo, I guess.