Trouble building CUDA SDK on Ubuntu 7.10

Hi Everyone,

I tried building the CUDA SDK, but I got the following errors after doing “sudo make”:

make[1]: Entering directory /home/paul/NVIDIA_CUDA_SDK/common' ar: creating ./../lib/libcutil.a a - obj/release/bank_checker.cpp_o a - obj/release/cmd_arg_reader.cpp_o a - obj/release/cutil.cpp_o a - obj/release/stopwatch.cpp_o a - obj/release/stopwatch_linux.cpp_o a - obj/release/multithreading.cpp_o make[1]: Leaving directory /home/paul/NVIDIA_CUDA_SDK/common’
make[1]: Entering directory /home/paul/NVIDIA_CUDA_SDK/common' a - obj/release/paramgl.cpp_o a - obj/release/param.cpp_o make[1]: Leaving directory /home/paul/NVIDIA_CUDA_SDK/common’
make -C projects/bitonic/
make[1]: Entering directory /home/paul/NVIDIA_CUDA_SDK/projects/bitonic' make[1]: nvcc: Command not found make[1]: *** [obj/release/bitonic.cu_o] Error 127 make[1]: Leaving directory /home/paul/NVIDIA_CUDA_SDK/projects/bitonic’
make: *** [projects/bitonic/Makefile.ph_build] Error 2

I’m not sure why I get “make[1]: nvcc: Command not found” since I added the CUDA bin path to $PATH and the CUDA lib path to $LD_LIBRARY_PATH. When I type “nvcc” in the terminal, it works…

Any help would be much appreciated! Thanks.

Cheers,

Paul

sudo is going to run make as root and is probably ignoring your user PATH setting as a security precaution. Since you have the SDK in your home directory, why not just run “make” without the sudo?

I tried but got this:

make[1]: Entering directory `/home/paul/NVIDIA_CUDA_SDK/common’

a - obj/release/bank_checker.cpp_o

a - obj/release/cmd_arg_reader.cpp_o

a - obj/release/cutil.cpp_o

a - obj/release/stopwatch.cpp_o

a - obj/release/stopwatch_linux.cpp_o

a - obj/release/multithreading.cpp_o

ar: could not create temporary file whilst writing archive: No more archived files

make[1]: *** […/lib/libcutil.a] Error 1

make[1]: Leaving directory `/home/paul/NVIDIA_CUDA_SDK/common’

make: *** [lib/libcutil.so] Error 2

Any idea what’s going on? I tried changing the permissions of the directories, but that didn’t help either. Thanks for the help.

Ok…so I’m an idiot…this was a directory permission problem. Gave r/w access to the folder and everything worked. ^^

I have this same error. I’ve tried with ‘su’ or without. I’ve also given read/write permissions to all folders and subfolders. What did you do to resolve it?

Thanks, -CS

$ make

make[1]: Entering directory `/home/user1/production/cuda/common’

a - obj/release/bank_checker.cpp_o

a - obj/release/cmd_arg_reader.cpp_o

a - obj/release/cutil.cpp_o

a - obj/release/stopwatch.cpp_o

a - obj/release/stopwatch_linux.cpp_o

a - obj/release/multithreading.cpp_o

make[1]: Leaving directory `/home/user1/production/cuda/common’

make[1]: Entering directory `/home/user1/production/cuda/common’

In file included from ./…/common/inc/paramgl.h:13,

             from src/paramgl.cpp:8:

./…/common/inc/GL/glut.h:60:20: error: GL/glu.h: No such file or directory

make[1]: *** [obj/release/paramgl.cpp_o] Error 1

make[1]: Leaving directory `/home/user1/production/cuda/common’

make: *** [lib/libparamgl.so] Error 2

install the freeglut-dev package or whatever Ubuntu calls it

GLU != glut

You need to install libglu1-mesa-dev.