Trouble Emulating an NVIDIA Jetson Orin NX Using the NVIDIA Jetson AGX Orin Developer Kit

We are attempting to emulate the Orin NX 8GB on an Orin AGX. Due to the size of our test environment, we need to do this on NVME SSD similar to as outlined in this forum post:

My environment
Host PC: ubuntu 20.04, also has latest SDK manager
L4T: 35.5.0
Jetson: AGX Orin 64GB Developer Kit

Host PC log:
flash_1-3_0_20240430-165844.log (40.9 KB)

I have referenced and followed the various guides, videos and forum posts here
here, and here

I have tried several iterations/variations of getting the basic emulation to work from eMMC including:

  • Removing nvme and following emulation flash procedure only for eMMC
  • Flashing eMMC using SDK Manager to Jetpack 5.1.3 then installing formatted NVME and following emulation flash procedure for r35.5.0
  • Flashing nvme using emulation flash procedure from host Linux PC, which appears to complete successfully, removing nvme, reflashing eMMC using SDK Manager (which completes successfully), reinstalling flashed NVME and trying to boot from this using boot manager.

None of the above have worked. I either get a working SDK Manager installed Jetpack 5.1.3, or I get a black screen on boot after the nVidia splash, or I get loop booting where the Jetson just keeps rebooting to the nVidia splash screen and does not proceed.

Is there an updated / alternate process for doing what we are trying to do that I should be following? I can provide logs and commands used if that is helpful.


Hi peter.chow1,

Do you want to flash AGX Orin devkit with the Orin NX 8G configuration to emulate it?
If so, please try using the following command for this use case.

$ sudo ./ jetson-agx-orin-devkit-as-nx-8gb mmcblk0p1

Please share the full flash log if you flash failed, or serial console log if you have boot issue.

Yes that is correct, we want to flash AGX Orin 64GB Devkit with Orin NX 8G config. I am happy to repeat that command and share the two logs. May I also confirm that these are the correct files we should be using:


Downloaded from this page:

And then following these instructions:

After which I will run the command you specified above?

Keep in mind, that if this works (which would be a great start), we still need to replicate this to the nvme SSD for the increased disk space.


Here is the serial bootlog of the problem we’re experiencing now:
Jetson_Orin_AGX-as-NX-8GB_Bootlog.txt (162.7 KB)

I previously provided the log of the install. I will now repeat all the flashing steps from the beginning and provide those logs.

I have repeated the emulation flashing steps from the beginning and am experiencing the same issue.

Flashing log:
Jetson_Orin_AGX-as-NX-8GB_FLASH-LOG.txt (92.3 KB)

Cold Boot Log, post “successful” flash:
Jetson_Orin_AGX-as-NX-8GB_Bootlog-NEW-FLASH.txt (69.7 KB)

Any help / instructions would be great!


*** The target t186ref has been flashed successfully. ***
Reset the board to boot from internal eMMC.

It seems the board has been flashed successfully.

[   20.774757] Please complete system configuration setup on the serial port provided by Jetson's USB device mode connection. e.g. /dev/ttyACMx where x can 0, 1, 2 etc.

From your serial console log, it is waiting you to finish the system configuration during first boot for username/password.
You can also refer to Flashing Support — Skipping oem-config to pre-configure them before flash.

1 Like

I did see that message, and tried to figure out what it meant since I already had a serial connection to the device but this menu was not loading. Turns out:

  • The Jetson Orin AGX will create two serial port connections - one on the Micro USB port that I was using to monitor boot and configuration process and one via the USB-C interface that connects the device to the host flashing machine
  • In my case, the Micro USB connection to the host was at /dev/ttyACM0 and the serial port presenting the configuration menu was at /dev/ttyACM4 and this was not evident until I had disconnected the Micro USB connection to the host and saw that only the ACM4 (USB-C) serial connection remained.

I will proceed from this point through the config, you may mark this closed and answered. Thank you!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.