Emulating an NVIDIA Jetson Orin NX Using the NVIDIA Jetson AGX Orin Developer Kit

Originally published at: https://developer.nvidia.com/blog/emulating-an-nvidia-jetson-orin-nx-using-the-nvidia-jetson-agx-orin-developer-kit/

Discover how to use the NVIDIA Jetson AGX Orin Developer Kit to emulate natively any of the NVIDIA Jetson Orin modules, including Jetson Orin NX and Jetson Orin Nano.

We are attempting to emulate the Orin NX 8GB on an Orin AGX. Due to the size of our test environment, we need to do this on NVME SSD similar to as outlined in this forum post:

My environment
Host PC: ubuntu 20.04, also has latest SDK manager
L4T: 35.5.0
Jetson: AGX Orin 64GB Developer Kit

Host PC log:
flash_1-3_0_20240430-165844.log (40.9 KB)

I have referenced and followed the various guides, videos and forum posts here
here, and here

I have tried several iterations/variations of getting the basic emulation to work from eMMC including:

  • Removing nvme and following emulation flash procedure only for eMMC
  • Flashing eMMC using SDK Manager to Jetpack 5.1.3 then installing formatted NVME and following emulation flash procedure for r35.5.0
  • Flashing nvme using emulation flash procedure from host Linux PC, which appears to complete successfully, removing nvme, reflashing eMMC using SDK Manager (which completes successfully), reinstalling flashed NVME and trying to boot from this using boot manager.

None of the above have worked. I either get a working SDK Manager installed Jetpack 5.1.3, or I get a black screen on boot after the nVidia splash, or I get loop booting where the Jetson just keeps rebooting to the nVidia splash screen and does not proceed.

Is there an updated / alternate process for doing what we are trying to do that I should be following? I can provide logs and commands used if that is helpful.


Hi @peter.chow1,

Welcome to the forums! You should post your issue in the Jetson forums so that the support team has visibility.


Thanks, reposted there.

1 Like