Trouble Ubuntu 21.10 and GPU GeForce GT 755M in LenovoY510p

Hello, actually I use a Lenovo Y510P for work and have a GPU Nvidia, GeForce GT 755M. This Graphichcard is alive, when tried with Windows, all run ok, but since change to Linux never works, specially with Ubuntu.

I tried installa with GUI and terminal, but not lucky.

I rebooted thousend times and no have result.

just I had this return with “nvidia-smi” : “No devices were found”

Somebody can help me with this trouble?

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Ok, thanks for the answer. Here’s the log, it’s some extensive.

I wait for your support =)

nvidia-bug-report.log.gz (162.4 KB)

[    6.321901] NVRM: GPU 0000:01:00.0: Failed to copy vbios to system memory.
[    6.322174] NVRM: GPU 0000:01:00.0: RmInitAdapter failed! (0x30:0xffff:874)

Please do a bios update to check if that resolves it.

Do you know how can I do for update my BIOS with ubuntu, because in lenovo page support just available update bios for windows?

I need change to windows for update and then return to linux?

That’s the wrong update, it’s for the dual-nvidia version of your notebook. The correct one is this:
https://pcsupport.lenovo.com/pe/es/products/laptops-and-netbooks/ideapad-y-series-laptops/ideapad-y510p-notebook/downloads/ds100556-bios-update-for-windows-7-32-bit-64-bit-windows-8-32-bit-64-bit-windows-81-32-bit-64-bit-ideapad-y410p-y510p

Though you need Windows to apply it, a Win PE thumb drive might suffice:
https://superuser.com/questions/1518167/create-a-bootable-usb-of-windows-pe-on-linux

ok, just I updated the bios and have this result after run
$nvidia-smi

So, now what, my GPU all works fine?

Yes, it’s in offload aka on-demand mode now.
https://download.nvidia.com/XFree86/Linux-x86_64/495.44/README/primerenderoffload.html
If you want everything to run on the nvidia gpu, run
sudo prime-select nvidia
and reboot.

OMG! thank very much! really.

One question more, recently I have new trouble, when sleep the laptop, never wake up (or closed) , I have a bug “nvidia-sleep” and have a black screen =S … Maybe do you have some advice?

Please create a new nvidia-bug-report.log

ok, here’s the log.
nvidia-bug-report.log.gz (306.6 KB)

Please set kernel parameter
nvidia.NVreg_PreserveVideoMemoryAllocations=1
https://download.nvidia.com/XFree86/Linux-x86_64/495.44/README/powermanagement.html#PreserveAllVide719f0

if that doesn’t work, try the opposite, leave the parameter on 0 but disable the systemd units nvidia-suspend, nvidia-resume and nvidia-hibernate

Hello, sorry for delay, but I have the same trouble =S