Trouble Ubuntu 21.10 and GPU GeForce GT 755M in LenovoY510p

Hello, actually I use a Lenovo Y510P for work and have a GPU Nvidia, GeForce GT 755M. This Graphichcard is alive, when tried with Windows, all run ok, but since change to Linux never works, specially with Ubuntu.

I tried installa with GUI and terminal, but not lucky.

I rebooted thousend times and no have result.

just I had this return with “nvidia-smi” : “No devices were found”

Somebody can help me with this trouble?

Please run as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Ok, thanks for the answer. Here’s the log, it’s some extensive.

I wait for your support =)

nvidia-bug-report.log.gz (162.4 KB)

[    6.321901] NVRM: GPU 0000:01:00.0: Failed to copy vbios to system memory.
[    6.322174] NVRM: GPU 0000:01:00.0: RmInitAdapter failed! (0x30:0xffff:874)

Please do a bios update to check if that resolves it.

Do you know how can I do for update my BIOS with ubuntu, because in lenovo page support just available update bios for windows?

I need change to windows for update and then return to linux?

That’s the wrong update, it’s for the dual-nvidia version of your notebook. The correct one is this:

Though you need Windows to apply it, a Win PE thumb drive might suffice:

ok, just I updated the bios and have this result after run

So, now what, my GPU all works fine?

Yes, it’s in offload aka on-demand mode now.
If you want everything to run on the nvidia gpu, run
sudo prime-select nvidia
and reboot.

OMG! thank very much! really.

One question more, recently I have new trouble, when sleep the laptop, never wake up (or closed) , I have a bug “nvidia-sleep” and have a black screen =S … Maybe do you have some advice?

Please create a new nvidia-bug-report.log

ok, here’s the log.
nvidia-bug-report.log.gz (306.6 KB)

Please set kernel parameter

if that doesn’t work, try the opposite, leave the parameter on 0 but disable the systemd units nvidia-suspend, nvidia-resume and nvidia-hibernate

Hello, sorry for delay, but I have the same trouble =S

Hello Again, I’m here! … and I have the same trouble when try suspend my laptop. Can you have any idea how to fix it?

Looking at the screenshot, this seems to be an issue of the audio device. Please see this for a workaround:

I followed the steps in each answer and have he same trouble , in fact the last step was “nvidia-smi -pm ENABLED”

This is the recently screen after close my laptop and open again.



If you dont have this file, just create.

vim /etc/udev/rules.d/10-remove-nvidia-audio.rules

  • then add this line

ACTION=="add", KERNEL=="0000:01:00.1", SUBSYSTEM=="pci", RUN+="/bin/sh -c 'echo 1 > /sys/bus/pci/devices/0000:01:00.1/remove'"

  • then, just run this command update-initramfs -u

Work for me!, thanks!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.