TX2 custom carrier board PCIex4 not working, odmdata, device tree, clkreq problem?

We are facing a TX2 pcie problem. we designed a schematic following the Nvidia Carrier Board, and the configuration is the same as nvidia carrier board. We used a plx pex8618 pcie switch to swith pcie x4 to 4 pciex1, so we can connect 4 intel i211 lan. now the switch pex8616 and the i211 both do not have the pcie clkreq# signal, so we connect the clkreq# to a optional 0ohm resistor to GND, but there is no different. we can not find pcie lan device using lspci. Do not know how to fix the problem: clkreq#? device tree? odmdata? Thanks for some guidance.

Hi, do you use r28.1?

Hi DaneLLL:
I’m using R27.1, thanks. please give me some advice, thanks.

Kevin

Hi DaneLLL:
I have reviewed all the pcie topics, could you help giving some advice? clkreq# or configuration? thanks.

Hi,
On r27.1, you have to do two steps:
https://devtalk.nvidia.com/default/topic/1024105/jetson-tx2/tx2-usb2-0-not-working-how-to-fix-it/post/5214439/#5214439
https://elinux.org/Jetson/TX2_USB

DaneLLL:
Thanks.

@DaneLLL Hello, DaneLLL. I encountered the same problem when trying using the 1x4 PCIe port.

I tried to replace the tegra186-mb1-bct-pmic-quill-p3310-1000-c03.cfg file according to https://devtalk.nvidia.com/default/topic/1024105/jetson-tx2/tx2-usb2-0-not-working-how-to-fix-it/post/5214439/#5214439. After that, I re-flash the customized mother-board. However, it seemed as if there was no changes. I wonder what should I do except for replacing the.cfg file. Should I reinstall the JetPack R27.1 on the host computer?

Meanwhile, could you tell me how the .cfg file works ?

Thanks a lot.

The solution has been verified. Do you see any error in boot log? Or you may try r28.1.

Hi hitter,

Is this still an issue after upgraded to R28.1?
Please share the result then can know how to support.

Thanks

@kayccc Hello, kayccc. We tried to upgrade to R28.1. But we encountered a new problem. TX2 did not display the desktop environment after booting up when using our customized mother-board. The debug UART said:
“tegradc 15210000.nvdisplay: sanitize_flip_args: WIN 3 invalid size:w=0,h=0,out_w=0,out_h=0”
However, the problem did not happen when using the TX2 evaluation kit. We are confused because we did not change the HDMI circuit and the configuration files. Could you tell us what we should do? Thank you!

This looks different from the PCIe issue in this thread. Please start a new thread for the new issue.

@DaneLLL OK. I will start a new thread for this new issue. Meanwhile, I note that the PCIe switch was recognized after upgrading the system to R28.1. Maybe we should use the latest JetPack when developing a customized mother-board. Thank you for your help.