TX2 PCIe#1_0 does not work

We have a TX2 carrier board with config4 setting.
After we modified dtb to config4, the PCIe#1_0 did not work.

Our pin mapping:
[USB1]
USB1_D (A38, A39)
USB_SS0 (F43, F44, C43, C44)

USB_SS0 connect to a USB hub and the hub connect to two USB type A port.

[USB2]
USB1_D (A38, A39)
USB_SS1 (G42, G43, D42, D43)

[PCIe#1_0]
Tx2 PEX2 connect to an ethernet convreter

Followed https://elinux.org/Jetson/TX2_USB to modify ODMDATA to 0x7090000 to use config#4 USB lane mapping.
as we run lspci and PCIe#1_0 does not see any pci port.
Due to it connects to a etherent converter, pci poer should show data as we run lspci.
Could we missed any?
Thank you for any advice.

Modified hardware/nvidia/platform/t18x/quill/kernel-dts/tegra186-quill-p3310-1000-c03-00-base.dts. as below.

xudc@3550000 {
    status = "okay";
    phys = <&tegra_xusb_padctl TEGRA_PADCTL_PHY_UTMI_P(1)>,
	<&tegra_xusb_padctl TEGRA_PADCTL_PHY_USB3_P(0)>;
    phy-names = "usb2", "usb3";
};


xhci@3530000 {
        status = "okay";
        phys = <&tegra_xusb_padctl TEGRA_PADCTL_PHY_UTMI_P(0)>,
            <&tegra_xusb_padctl TEGRA_PADCTL_PHY_UTMI_P(1)>,
            <&tegra_xusb_padctl TEGRA_PADCTL_PHY_UTMI_P(2)>,
            <&tegra_xusb_padctl TEGRA_PADCTL_PHY_USB3_P(0)>,
            <&tegra_xusb_padctl TEGRA_PADCTL_PHY_USB3_P(1)>,
            <&tegra_xusb_padctl TEGRA_PADCTL_PHY_USB3_P(2)>;
        phy-names = "utmi-0", "utmi-1", "utmi-2", "usb3-0", "usb3-1", "usb3-2";
    };

    pinctrl@3520000 {
        status = "okay";
        pinctrl-0 = <&tegra_xusb_padctl_pinmux_default>;
        pinctrl-1 = <&vbus_en0_sfio_tristate_state>;
        pinctrl-2 = <&vbus_en1_sfio_tristate_state>;
        pinctrl-3 = <&vbus_en0_sfio_passthrough_state>;
        pinctrl-4 = <&vbus_en1_sfio_passthrough_state>;
        pinctrl-5 = <&vbus_en0_default_state>;
        pinctrl-6 = <&vbus_en1_default_state>;
        pinctrl-names = "default",
            "vbus_en0_sfio_tristate", "vbus_en1_sfio_tristate",
            "vbus_en0_sfio_passthrough", "vbus_en1_sfio_passthrough",
            "vbus_en0_default", "vbus_en1_default";
        tegra_xusb_padctl_pinmux_default: pinmux {
            /* Quill does not support usb3-micro AB */
            usb2-micro-AB {
                nvidia,lanes = "otg-0";
                nvidia,function = "xusb";
                nvidia,port-cap = <TEGRA_PADCTL_PORT_OTG_CAP>;
                status = "okay";
            };
            usb2-micro-AB {
                nvidia,lanes = "otg-0";
                nvidia,function = "xusb";
                nvidia,port-cap = <TEGRA_PADCTL_PORT_OTG_CAP>;
                status = "okay";
            };
            usb2-std-A-port2 {
                nvidia,lanes = "otg-1";
                nvidia,function = "xusb";
                nvidia,port-cap = <TEGRA_PADCTL_PORT_HOST_ONLY>;
                status = "okay";
            };
	usb3-std-A-port2 {
		nvidia,lanes = "usb3-0";
		nvidia,port-cap = <TEGRA_PADCTL_PORT_HOST_ONLY>;
		status = "okay";
	};
	usb3-std-A-port3 {
		nvidia,lanes = "usb3-2";
		nvidia,port-cap = <TEGRA_PADCTL_PORT_HOST_ONLY>;
		status = "okay";
	};
	usb3-std-A-port4 {
		nvidia,lanes = "usb3-1";
		nvidia,port-cap = <TEGRA_PADCTL_PORT_HOST_ONLY>;
		status = "okay";
	};
        };
    };

   pcie-controller@10003000 {
        status = "okay";
        pci@1,0 {
            nvidia,num-lanes = <2>;
            nvidia,disable-clock-request;
            status = "okay";
        };
        pci@2,0 {
            nvidia,num-lanes = <1>;
            status = "okay";
        };
        pci@3,0 {
            nvidia,num-lanes = <1>;
            status = "disabled";
        };
    };

attached the log

tx2_conf4_usb-1.txt (83.9 KB)

Your log indicates pcie is using 4,0,1 configuration.

[    7.344633] tegra-pcie 10003000.pcie-controller: 4x1, 1x1 configuration

Please check if you disable the plugin-manager. The elinux page points out where to disable.

Hi WayneWWW,

Thank you for your prompt support.
Yes. It’s my bad. I missed up the file.
After disabled the plugin-manager, the PCIe#1 worked.

Thanks