TX2i USB Lane Mapping Config 1

This is on Jetpack 3.3

I am unsuccessfully trying to configure the USB lane mapping for configuration 1 on the TX2i. The main goal is to switch enable PCIe on PEX1. I was successfully able to follow the instructions in the following link to get the it working on the TX2.

https://devtalk.nvidia.com/default/topic/1023160/jetson-tx2/tx2-using-pcix1-instead-of-usb3-default-config-1-/post/5208073/#5208073

Trying to follow this same process for the TX2i has not been successful. Below are the configuration changes I made to the device tree:

I set ODMDATA=0x90000 in p2771-0000.conf.common.

In tegra186-quill-p3489-1000-a00-plugin-manager.dtsi and tegra186-quill-p3489-1000-a00-00-base.dts set xhci@3530000 with

phys = <&tegra_xusb_padctl TEGRA_PADCTL_PHY_UTMI_P(0)>;
phy-names = “utmi-0”;

In tegra186-quill-p3489-1000-a00-00-base.dts set the status to disabled for usb2-std-A-port2 and usb3-std-A-port2

In tegra186-quill-common-p3489-1000-a00.dtsi enable pcie0_lane2_mux by setting the status to “okay”.

In tegra186-quill-power-tree-p3489-1000-a00-00.dtsi under pinctrl@3520000 set vbus-2-supply = <&battery_reg>;

comment out fragment-500-e3325-pcie in tegra186-quill-p3489-1000-a00-plugin-manager.dtsi

Am I missing something for the TX2i configuration? Could someone give me a step by step list of all the changes that need to be made in the device tree to enable configuration 1 on the tx2i?

Hi,
PLease check if you have pci@3,0 added:
https://devtalk.nvidia.com/default/topic/1056650/jetson-tx2/usb-lane-mapping-config-1-on-tx2-dev-kit-board/post/5357833/#5357833

I believe it is set in tegra186-quill-p3489-1000-a00-00-base.dts

pcie-controller@10003000 {
		status = "okay";
		pci@1,0 {
			nvidia,num-lanes = <2>;
			status = "okay";
		};
		pci@2,0 {
			nvidia,num-lanes = <1>;
			status = "disabled";
		};
		pci@3,0 {
			nvidia,num-lanes = <1>;
			nvidia,disable-clock-request;
			status = "okay";
		};
	};

I added nvidia,disable-clock-request; to pci@3,0 as per the link you sent me and I still don’t get the PCIe card to show up on the TX2i like it does on the TX2.

looks like pci@3,0 is okay, but it is not showing the card.

nvidia@tegra-ubuntu:~$ xxd /proc/device-tree/pcie-controller@10003000/pci@3\,0/status
00000000: 6f6b 6179 00                             okay.

I attached all the device tree files I edited if that helps.
p2771-0000.conf.common.txt (8.37 KB)
tegra186-quill-common-p3489-1000-a00.txt (2.53 KB)
tegra186-quill-p3489-1000-a00-00-base.txt (5.72 KB)
tegra186-quill-power-tree-p3489-1000-a00-00.txt (8.61 KB)
tegra186-quill-p3489-1000-a00-plugin-manager.txt (9.18 KB)

Hi,
Please also modify below line in p2771-0000.conf.common

elif [ "${bid}" \= "3489" ]; then
		<b>ODMDATA=0x90000;</b>
		tofab="-a00";
		pmicfab="-a00";
		bpfdtbfab="-a00";
		tbcdtbfab="-a00";
		kerndtbfab="-a00";
		if [ "${bdv}" \< "300" ]; then
			bpfdtbfab="-evt";
		fi

And check if you see enable-pcie-on-uphy-lane0 instead of enable-xusb-on-uphy-lane0

$ ls /proc/device-tree/chosen/plugin-manager/odm-data

That was the problem. Thank you!