TX2 fails to link to SATA controller on custom board

Hi,

We have our own custom board that is a slim down version of the Jetson TX1 DevKit board. If we use TX1, it sees the SATA controller and kernel log shows “ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)”. In Ubutun, we can then use parted and mkfs.ntfs on /dev/sda. If you we use TX2, we get “ata1: SATA link down (SStatus 0 SControl 300)” and there is no sign of /dev/sda when executing “fdisk -l”.

BTW, both TX1 and TX2 get “SATA link up” on the Jetson TX1/TX2 DevKit boards and parted/mkfs.ntfs see /dev/sda.

Has anyone run into this issue or can anyone give us a clue why the TX2 has this SATA issue?

Thanks,
Tom

NTFS is not enabled by default, so I assume there were kernel changes compared to the default kernel. A kernel config change would be my first guess (perhaps including device tree), followed by a signal quality issue. The TX1 works, so signal quality is not necessarily an issue of hardware/electrical…there may be drive strength changes in software which make the TX2 more or less sensitive to signal quality (which goes back to kernel config).

Hi linuxdev,

Do you know what to look out for in the kernel config? Like what to enable and what to disable. I have gone through the configs related to SATA and toggle them but still no success.

The default the Jetson ships with should be enabled. For different carrier boards though there may be something different required in the device tree. I’m not where I can check what that is at the moment. Anyone know what device tree entries might need to be changed when the carrier board changes?

Pleae check https://devtalk.nvidia.com/default/topic/1013740/jetson-tx2/tx2-config-3-for-usb-lane-mapping/post/5167269/#5167269

It should work if you modify the cfg files accordingly.

Hi Dane,

I tried to follow the threads related to USB lane mapping and configuration changes but those did not solve my issue; the threads don’t specifically tackle the SATA link down issue. Do you have instructions on how to solve my issue specifically?

Thanks,
Tom

The new JetPack 3.1 with Tegra r28.1 seems to have fixed this issue.