usb usb2-port1: Cannot enable. Maybe the USB cable is bad? with L4T 32.1 Release

I am using the latest revision of L4T on my custom carrier board. I am using configuration #2 of the USB 3.0 lane mapping.My USB 3.0 is USB 2.0 compatible. I would like to use an additional USB 2.0.

On Jetson TX2 developer kit the USB2_D+/- are routed to an M.2 connector. I have routed those lines to a USB 2.0 connector. When I test my USB 2.0 connector I get the following error:

“usb usb2-port1: Cannot enable. Maybe the USB cable is bad?”

How do I enable usb2 port 1 on my carrier board? Has anyone ran into this issue?

I just found out that the port that is not in fact working is actually usb usb2-port2 per OEM Design guide. I know the lines I am trying to use go directly to the M.2 connector on the Jetson Developers Kit.I believe I have to modify the device tree. I am not sure what exactly I would have to enable in order to get this lane working.

Please refer to adaptation guide for device tree programming.

Also debug tips are at
https://devtalk.nvidia.com/default/topic/1048285/jetson-tx2/how-to-setup-usb-config-4-for-tx2-l4t-28-2-1-/post/5320806/#5320806

I have looked at the TX2 Adaptation guide and couldn’t allocate additional documentation like the padctl.txt document that is called out to give further info on UPHY lanes.

I am using the same default configuration as the Jetson Developer Kit( Configuration #2). Configuration #4 does not fit my requirements. Can the Jetson TX2 only be configured 4 ways.

I currently have (1 SATA, 1 x4 PCIe lanes, 1 USB 3.0) but I would like to add an additional USB2.0 lane which USB2_D+/- which I have routed on my custom board to a USB2.0 connector. I can’t get it to work. How do I configure this additional lane without changing any of the interfaces I already have working on my custom board?

The adaptation guide should be clear for device tree programming of USB lane mapping. Yo may also check oem design guide:
http://developer.nvidia.com/embedded/dlc/jetson-tx1-oem-product-design-guide

USB2_D+/- is B42 and B43. You need to add otg-3 to pinctrl@7009f000 and utmi-3 to xusb@70090000