USB problem of Jetson TX2 Custom board


I made a Jetson tx2 custom board.

I installed the OS on a custom board and checked each port after booting.
(L4T r32.3.1)
Ethernet and HDMI on the custom board are working fine .
USB have problem.

The custom board has one usb 2.0 micro-b and two usb 3.0 type-a.
I can install ubuntu os using usb2.0 micro-b.
But usb 2.0 micro-b and two usb 3.0 type-a cannot be used in host mode.

How do I edit dts and dtsi files?

The USB pin used are as follows.

#USB 3.0 Type-A port

  • USB_SSO_RX (F44, F43)
  • USB_SSO_TX (C44, C43)
  • USB1_D (A38, A39)
  • USB1_EN_OC (A18)

  • USB_SS1_RX (G42, G43)
  • USB_SS1_TX (D42, D43)
  • USB2_D (B42, B43)
  • USB2_EN_OC (A19)

#USB 2.0 micro-b port

  • USB0_D (B40, B39)
  • USB0_EN_OC (A17)
  • USB0_OTG_ID (A36)
  • USB0_VBUS_DEF (B37)

This is the kernel log captured at boot time.

And I tried following the methods in the link below, but the problem was not resolved.


Please check the TX2 adaptation guide on dlc.

Also, please share any log from dmesg as a text file. We don’t use the log on screen to debug.

I tried the method in the link below with version L4T r28.2.1 again.

The hardware is the same.
This time, USB 2.0 micro-b port is working
and USB 3.0 Type-A port works only on one side(USB_SSO_RX,USB_SSO_TX,USB1_D,USB1_EN_OC).

The log obtained by the dmesg command is uploaded.
kernel.log (57.0 KB)


rel-28.2.1 dts is not compatible with rel-32. Please do not refer to any of reference that are on rel-28.

Please do read adaptation guide here.