TX2 flashing problem

Hello, I recently bought the Jetson tx2 development kit. I have a Windows 10 PC where I created first an Ubuntu 14.04 virtual machine (but didn’t finish the installation) , then I created an Ubuntu 16.04 virtual machine. I followed (in both case) the tutorial video and the pdf guide for the installation of the jetsonpack 3.3 but unfortunately it still doesn’t finish the installation.I searched a solution in the forum but unfortunately, the installation did not complete. I have seen that other users had this problem, but no one has perhaps solved it. Is it possible to install without using the USB port? Maybe directly on an SD card? Thanks

VMs usually fail, they lose the USB. Some people have made them work by correctly binding the USB to the VM such that the VM will always get that device. VMs are not officially supported.

Also understand that if the VM works, then the underlying file system type must be a native Linux type. Running a VM on top of NTFS or VFAT will appear to work, but then the Jetson will crash and burn.

You’d be better off with a dual boot setup.

Thanks for the info. Nvidia should write that the VM is not supported if not everyone becomes crazy trying to find solutions without success.

NVIDIA has documented that you need to use a real OS instance, and not a VM. It’s in the documentation!

Btw, a VM can work, it just doesn’t normally work unless you are either lucky, or are an expert on configuring the USB pass through. A VM definitely isn’t plug-n-play.