Jetson TX2 flash failed


I flash tx2 on VMware ubuntu 16.04, when i execute the below command,then, ubuntu was crashed, freezed.
cmd:sudo ./ jetson-tx2 mmcblk0p1

In the same environment,include tx2 board, host os. i flash tx2 successfully.

VMs are not officially supported as their setup is custom to each VM. That said, it can work if you manage to set ownership of the USB port for the Jetson to the VM with no interference from the host o/s. During a flash the device mode (recovery mode) Jetson repeatedly connects and disconnects, and often a VM fails to reconnect after first connect.

but,before yesterday, erverything is ok,this problem popped up.and ths usb is aways directly connect to VM ubuntu.
Jeton will connects and disconnects when execute the below command?

sudo ./ -r -k kernel-dtb jetson-tx2 mmcblk0p1

so, how dose me fixed this iusse?

can i flash tx2 in windows 10?

In recovery mode the Jetson is a custom USB device. The driver package which understands that custom USB device runs only on a Linux PC architecture, and so Windows would be unable to run this without emulating Linux.

The specific flash command you gave is only for a partial flash of a partition. The command should work from a VM or a non-VM, but only if the VM is set up correctly and only if the command would work on a non-VM. In no case should the command crash the host PC (even if the command is invalid for a given setup), and so I suspect this is an error of the VM. There are no simple ways to debug a VM issue like this.

I have the same problem, have you solved it ?

I have the same problem, have you solved it ?

I have solved it by upgrade my vm software version to 15.5.