TX2 GPIO388 stays low

Hi there,
I want to use the PGIO8_ALS_PROX_INT pin H13 of TX2 as an input to detect an external switch. According to the pinmux, it is GPIO3_PI.04 equates to gpio388, default is input with an internal pullup.
However, when I looked at the pin, it is low. I thought the internal pullup is not activated so I added a 47K to 1.8V, but the level at the pin just went up to about 0.3V and not all the way to 1.8V.
What could be wrong with the pin setup? Please guide me through.

This is from the console:
BaseSystem_0_9:/sys/class/gpio/gpio388$ sudo cat active_low
BaseSystem_0_9:/sys/class/gpio/gpio388$ sudo cat direction

Thank you very much for your help.

hello tai0vi6u,

FYI, there’s pinmux documentation update.
please access the latest Jetson TX2 Series Pinmux for the v1.08 version, which released on Aug. 04, 2021.
as you can see, this pin, GPIO8_ALS_PROX_INT, it’s by default configured as input with Int PD.

Hi Jerry,

So this PD of 20K will override the “Internal pull-up to 1.8V” documented in the NVIDIA Jetson TX2 Series OEM Product Design Guide? Do I need to add an external pull up to 1.8V?

If the Internal pullup to 1.8V is still available, how do I disable the 20K pull down to make the signal an input with active low?

It is weak PD if be set as input. No pullup is available then.


Please confirm that if the “Jetson TX2 Series OEM Product Design Guide” Design Checklist for the following:
GPIO8/ALS_PROX_INT Internal pull-up to 1.8V .
Is this “Internal pull-up to 1.8V” not true?
If so, what other statements in the document we need to pay attention to?


Trumany and JerryChang,

To simplify the issue, here is what I am after:
I want to use GPIO8/ALS_PROX_INT pin H13 to detect the closure of a switch. Since the guide indicates the pin has an internal pullup to 1.8V, we did not provision an external pull up for the pin. We need to configure the pin to be input, with active low when the switch is closed. The issue now is the pin stays low all the time since the pulldown is on by default.

Please walk me through the steps to make this pin an input, with active low (normally stays high and will detect the low input)

Many thanks,

The pinmux is correct, the checklist in DG will be updated. The POR in the Pinmux is “pd”.


Thanks. SO is there a way to reconfigure the “pd” to become a “pu” after POR?

Sure, it can be set to that after POR.

This is where we are struggling with. Could you please help with steps to turn the internal resistor from pull down to pull up after POR?


hello tai0vi6u,

let’s back to your original request, and it’s pinmux configuration to update the settings.
you should access the latest Jetson TX2 Series Pinmux for the v1.08 version, you should toggle the settings of GPIO8_ALS_PROX_INT to have customization.
please also refer to Pinmux Changes session for the steps to customize the pinmux spreadsheet.
you’ll also need a tool, pinmux-dts2cfg.py it converts pinmux, gpio and pad dts file to cfg format, which can be found under $OUT/Linux_for_Tegra/kernel/pinmux/t186/


Thank you. I thought that’s what we have done for other pins; but we will try again and will post if we still need help.


We are able to reconfigure the pin for PU. Thank you very much for your help!