TX2 Jetpack 4.2.1 (L4T 32.2 and 32.1) Custom PCB SD Card Issue

We have custom PCB for the TX2 which we’ve used successfully for a long time with a micro SD card slot. Everything works just fine on L4T 28.2.1.

Having tried out L4T 32.2 and 32.1, our TX2 won’t boot at all with the SD card plugged in, and if we plug the SD in after a successful boot, the computer seemingly freezes and crashes. This is consistent behavior, and we’ve not been able to produce any issue with a TX2 running 28.2.1. We have an LED that indicates the SD slot has power, and that seems to be coming on despite the crash.

The TX2 we’re testing with has the stock OS image, stock device tree, stock driver, etc from Jetpack 4.2.1. We’ve tried both L4T 32.2 and 32.1 to see if we could isolate.

I’m not sure if there was a device tree or driver change that could cause a kernel panic or something of the sort, but this is only reproducible on our custom board which has no display output, making debugging cumbersome. I’m not sure if there’s a way to get dmesg or other logs from a previous boot which could be useful. Please advise, thank you.

It is common to debug with uart log for such case. Even with display, kernel panic would cause boot problem and you may not able to see the logs either.