Tx2 recovery not work

hi I have a tx2 developer kit and I already flash 2 or three times, but now I have to restore my jetson tx2 because the ros melodic system no longer works or rather it does not compile and has lost some functions, so in short, it is impossible for me to reset the tx2, through the sdk manager I download all the necessary files, but when I put the card in recovery mode it always gives me the same error as I attach images. I checked with the lsusb command and the card is connected and recognized, also at the top the sdk manager panel tells me that the tx2 is in recovery mode, but when it starts flashing the rom freezes and this message appears which I also find in the terminal that shows me sdk manager “Target Setup - target: Depends on failed component” I don’t think it’s a hardware problem but I’m not sure, because if I start the tx2 it works perfectly apart from the problems listed above with ros. I am using the original usb cable and the tx2 card is practically new it is more than a year that it is off it will have 2 hours of use and I do not understand what could have created problems. I repeat as soon as I bought it, after a few days I reinstalled the operating system from scratch with sdk manager and I had not encountered any problems, now I don’t know what is wrong. Besides I followed several procedures listed in the official Nvidia forum and I noticed that many are no longer able to flash the tx2, and I do not understand why when you start the tx2 in recovery mode there is no led or other thing that visually indicates the recovery status mode, 2 red LEDs and the two green LEDs next to the power and REC buttons light up steadily on my card, but nothing flashes and I don’t know if this is an indication of a problem, I don’t remember but when I flashed the card last year I don’t think LEDs were flashing. I also connected the tx2 card via USB Uart and Minicom terminal, which when the tx2 starts normally gives me the normal boot information and the status of the tx2, but if I put it in recovery it does not communicate anything via minicom and also when I start sdk mananger and I try to flash the minicom with no signs of life, I don’t know if it should send data. Would it be possible to use the uart channel to try to flash jetson tx2 or is it not provided? If you could help me because otherwise I have a completely useless card. It would also be enough without flashing tx2 to restore the original operating system, but I don’t know if it is possible. Thank you .

  1. Are you still able to enter the OS of the TX2 and open a terminal to give command?

  2. Do you have other TX2 modules or carrier board or even other kind of jetson (nano/NX) to validate your host?

  3. UART is low speed I/O. It is not possible to flash device with such interface.

  4. Have you tried flash.sh instead of sdkmanager?

Can you still access the TX2 operating system and open a terminal to give the command? "Of course the system works, but some Ros melodic commands that I had installed no longer recognize them and I didn’t understand why the card was in a closet for months off, maybe some updates when I turned it back on, so I wanted to restore it to settings factory, but it works. "

Do you have other TX2 modules or carrier boards or even other types of jetsons (nano / NX) to validate your host? "I have no other modules, but I don’t understand what you mean by validating my host, I had already flashed the tx2 last year with the same PC running Ubuntu 18.4 without any problems and I had done everything less than an hour, now I am having problems. "

UART is low speed I / O. The device cannot be flashed with this interface. “Ok”

You tried flash.sh instead of sdkmanager. No I will try you have a link that explains. well the method with all the steps? thank you.

  1. If you still can access the board, open terminal and use this command to put the board into recovery mode. This can prevent making mistakes with those buttons on the carrier board.

sudo reboot forced-recovery

  1. Quick start guide may help you know how to use flash.sh.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.